<!DOCTYPE html>
<html itemscope itemtype="http://schema.org/Article">
<head>
    <script data-cfasync='false' data-mrf-script="garda" data-mrf-dt="1" data-mrf-host="bc.marfeelcache.com" src="https://bc.marfeelcache.com/statics/marfeel/gardac-sync.js"></script>

        <script src="/js/prebid.js"></script>

    <title>Last Night: Peter Frampton at the Woodlands Pavilion | Houston Press</title>
<meta name="description" content="Peter Frampton bids farwell to Houston in powerhouse career-spanning show."/>
<meta name="author" content="Bob Ruggiero"/>
<meta name="keywords" content="Peter Frampton, Humble Pie, Jason Bonham, Led Zeppelin"/><meta property="og:type" content="article"/>
<meta property="og:title" content="Peter Frampton Says Goodbye to Houston in Powerful and Joyous Farewell Tour"/>
<meta property="og:description" content="While Peter Frampton has joined the long (and getting longer) list of classic rock-era acts who have decided to put an end to extended touring, in his case it doesn’t stem from any desire to actually leave the stage. In February, Frampton announced that he has a degenerative muscular disease..."/>
<meta property="og:url" content="https://www.houstonpress.com/music/last-night-peter-frampton-at-the-woodlands-pavilion-11358487"/>
<meta property="article:published_time" content="2019-09-22T06:41:00-05:00"/>
<meta property="article:modified_time" content="2019-09-22T07:13:43-05:00"/>
<meta property="article:section" content="Music"/>
<meta property="og:image" content="https://images1.houstonpress.com/imager/u/original/11358492/hou_mus_frampton1.jpg"/>
<meta property="og:image:height" content="1280"/>
<meta property="og:image:width" content="1920"/>
<meta property="og:site_name" content="Houston Press"/><meta itemprop="headline" content="Peter Frampton Says Goodbye to Houston in Powerful and Joyous Farewell Tour"/>
<meta itemprop="description" content="Peter Frampton bids farwell to Houston in powerhouse career-spanning show."/>
<meta name="news_keywords" content="Peter Frampton, Humble Pie, Jason Bonham, Led Zeppelin"/>
<meta itemprop="image" content="https://images1.houstonpress.com/imager/u/original/11358492/hou_mus_frampton1.jpg"/><meta property="twitter:title" content="Peter Frampton Says Goodbye to Houston in Powerful and Joyous Farewell Tour"/>
<meta property="twitter:description" content="While Peter Frampton has joined the long (and getting longer) list of classic rock-era acts who have decided to put an end to extended touring, in his case it doesn’t stem from any desire to actually leave the stage. In February, Frampton announced that he has a degenerative muscular disease..."/>
<meta property="twitter:card" content="summary_large_image"/>
<meta property="twitter:image" content="https://images1.houstonpress.com/imager/u/745xauto/11358492/hou_mus_frampton1.jpg"/>
<meta property="twitter:site" content="@houstonpress"/><meta property="fb:app_id" content="129990850394679"/><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><meta name="viewport" content="width=device-width, initial-scale=1"/><link href="/theme/hou/apple-touch-icon.png" rel="apple-touch-icon" sizes="192x192"/>
<link href="/theme/hou/apple-touch-icon.png" rel="icon" sizes="192x192"/><link href="/theme/hou/apple-touch-icon.png" rel="shortcut icon" sizes="192x192"/>
<meta name="mobile-web-app-capable" content="yes"/>
<link href="/theme/hou/favicon.ico" type="image/x-icon" rel="icon"/><link href="/theme/hou/favicon.ico" type="image/x-icon" rel="shortcut icon"/>
<link rel="stylesheet" type="text/css" href="/css_cache/hou-default.css?buildId=1568922512"/>
<link rel="stylesheet" type="text/css" href="/css_cache/content-view.css?buildId=1568922512"/>
<script type="text/javascript" src="/js_cache/hou-default.js?buildId=1568922512"></script>
<link rel="canonical" href="https://www.houstonpress.com/music/last-night-peter-frampton-at-the-woodlands-pavilion-11358487" /><meta name="theme-color" content="#0053b8"/>        <script type="text/javascript">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</script>
                <script type="text/javascript">
        var apntag = apntag || {};
        //create a queue on the apntag object
        apntag.anq = apntag.anq || [];

        //load ast.js - async
        (function() {
            var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
            e.type = 'text/javascript';  e.async = true;
            e.src = '//acdn.adnxs.com/ast/ast.js';
            p.insertBefore(e, p.firstChild);
            window.apntag.anq.push(function(){
                window.apntag.setPageOpts({
                    member: parseInt(9027),
                    publisherID: parseInt(1162525)
                });
            });
        })();
    </script>
        
        <script type="text/javascript">
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-395255-4', {
            'siteSpeedSampleRate': 5
        });

        // Set dimensions for use with each hit
        
                ga('set', 'dimension1', 'http://www.houstonpress.com/music');
            

                ga('set', 'dimension2', 'Music');
            

                ga('set', 'dimension7', 'Articles');
            

                ga('set', 'dimension3', '11358487');
            

                ga('set', 'dimension4', '2019-09-22 06:41:00');
            

                ga('set', 'dimension5', 'Classic Rock Corner%Concerts%History%Music%Rock');
            

                ga('set', 'dimension6', 'Bob Ruggiero');
            

        // Send for pageview hit type
        ga('send', 'pageview');

        </script>
          <div id="springserve-config" data-springservedisplay="both" data-springserveid="hpress" style="display:none"></div>
<script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js"></script>





<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>


        <!-- Hotjar Tracking Code for www.westword.com -->
        <script>
            (function(h,o,t,j,a,r){
                h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
                h._hjSettings={hjid:405233,hjsv:6};
                a=o.getElementsByTagName('head')[0];
                r=o.createElement('script');r.async=1;
                r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
                a.appendChild(r);
            })(window,document,'https://static.hotjar.com/c/hotjar-','.js?sv=');
        </script>

    <script type="text/javascript">
    if ('www.h' + 'ousto' + 'npres' + 's.com' != document.location.host && document.location.host != 'web.a' + 'rchiv' + 'e.org'  && document.location.host != 'webci' + 'tatio' + 'n.org') {
                //document.location.host = 'www.h' + 'ousto' + 'npres' + 's.com';
        document.location.host = 'http://microapp.vvmedia.com/destination/index.html';
    }

    </script>

            <script type="text/javascript">
            var scale = "95%";
    var category;
    var site_pathname = window.top.location.pathname;
    if (site_pathname.match(/restaurants/g)) {
      category = 'Restaurants';
    } else if (site_pathname.match(/film/g)) {
      category = 'Film';
    } else if (site_pathname.match(/news/g)) {
      category = 'News';
    } else if (site_pathname.match(/music/g)) {
      category = 'Music';
    } else if (site_pathname.match(/arts/g)) {
      category = 'Arts';
    } else {
      category = 'ROS';
    }
    </script>
    </head>
<body class="hou city-blue twitterTrue layout-lg" >
    <div style="display:none" id="sidebar-config" data-refresh-interval="25" data-refresh-enable="1" data-max-refresh="9"></div>
        <div class="wrapper">
        <div class="ads frame" data-vmg-ad="Frame" id="appnexus-ANReskin" data-pos="unknown" data-vmg-format="normal"></div>                <div class="all-body">
            <a name="top"></a>
            <div class="slide-body container-fluid scrolly">
                <div class="sde-shadow">
                    <nav>
                        <div class="nav-search">
                            <form id="search-form" method="get" action="/search">
                                <fieldset>
                                    <input type="text" name="keyword" id="q" value="" />
                                    <input type="submit" value="Search" class="sprite" />
                                </fieldset>
                            </form>
                        </div>
                        <ul class="top-level">
    <li ><a href="/">Home</a></li><li class="has-sub"><a href="/news">News</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/topic/sports-6362239" >Sports</a></li><li><a href="/longform" >Longform</a></li><li><a href="/profile?source_id=8|55|16268" >Daily Newsletter</a></li><li><a href="/profile?source_id=8|55|1378" >Weekly Newsletter</a></li></ul></li><li class="has-sub"><a href="/music">Music</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/concerts" >Concert Calendar</a></li><li><a href="/restaurants/guide?sort=name&bars=true&awards=none" >Bars & Lounges</a></li><li><a href="/profile?source_id=8|55|1380" >Music Newsletter</a></li></ul></li><li class="has-sub"><a href="/restaurants">Food & Drink</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/topic/restaurant-reviews-6362359" >Restaurant Reviews</a></li><li><a href="/restaurants/guide" >Restaurant Guide</a></li><li><a href="/profile?source_id=8|55|1381" >Food & Drink Newsletter</a></li></ul></li><li class="has-sub"><a href="/arts">Arts & Culture</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/topic/100-creatives-6362314" >100 Houston Creatives</a></li><li><a href="/topic/stage-6362234" >Stage</a></li><li><a href="/profile?source_id=8|55|1382" >Arts & Culture Promo Newsletter</a></li><li><a href="https://www.HoustonPressArtsGuide.com" >HoustonPressArtsGuide.com</a></li></ul></li><li class="has-sub"><a href="/things-to-do">Things To Do</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/calendar" >Calendar</a></li><li><a href="/submit-event" >Submit an Event</a></li><li><a href="/profile?source_id=8|55|1379" >Things To Do Newsletter</a></li></ul></li><li ><a href="/longform">Longform</a></li><li ><a href="https://www.herbanplanet.com">Marijuana</a></li><li ><a href="/videos">Videos</a></li><li ><a href="/slideshows">Slideshows</a></li><li class="has-sub"><a href="/best-of">Best Of Houston<sup>®</sup></a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="http://readerschoice.houstonpress.com/" >Reader's Choice Nominations</a></li><li><a href="/profile?source_id=8|55|1384" >Best Of Newsletter</a></li><li><a href="http://houstonpress.newskeepsake.com/BOH.html" >Winners Awards</a></li></ul></li><li class="has-sub"><a href="/promotions">Promotions</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/calendar?categories%5B%5D=Promotional%20Events" >Promotional Events</a></li><li><a href="/promotions/street-team" >Street Team</a></li><li><a href="/promotions/free-stuff" >Free Stuff</a></li><li><a href="/profile?source_id=8|55|1385" >Promotions Newsletter</a></li><li><a href="http://coupons.houstonpress.com" >Deals</a></li></ul></li><li ><a href="/classifieds">Classifieds</a></li><li ><a href="/advertise">Advertise</a></li></ul>
<p class="misc">
        <a href="/about">About Us</a>,
    <a href="/about/contact">Contact Us</a>,
    <a href="/about/staff">Staff</a>,
    <a href="/about/careers">Careers</a>,
    <a href="/about/privacy-policy">Privacy</a>,
    <a href="/about/terms-of-use">Terms</a>
    ,
    <a href="/about/help">Help</a>
</p>
                    </nav>
                    <div class="masthead sticky-bar"><!-- toggle .active on .hamburger click -->
                        <a class="logo" href="/"><img src="/theme/hou/img/logo-home.png" alt="Houston Press, LP"/></a>
                        <div class="styro"><a id="hamburger"><span>&nbsp;</span></a></div>
                        <div class="sb-hidey" id="sectionContent"></div>
                            <ul class="socials masthead-socials">
        
        <style type="text/css">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</style>
        <div class="main-container" id='login-modal'>
            <p class="error" id="login-error"></p>
            <form id="login" method="POST">
                <input type="text" id="email" name="email" placeholder="Email"/>
                <input type="password" id="password" name="password" placeholder="Password"/>
                <input type="hidden" id="cid" name="cid" value="hou"/>
                <div class="remember-forgot">
                    <div class="rem"><label for="rememberMe"><input type="checkbox" checked id="rememberMe" name="rememberMe"/> Remember Me</div>
                    <button type="submit">SIGN IN &rsaquo;</button><br/>
                    <a href="javascript:;" id="forgot" tabindex="4" class="city-color">Forgot Password?</a>
                </div>

            </form>

            <div id="social">
                <p>Or sign in with a social account:</p>
                <span data-omni-action="facebook|sid[8|22|37]|slider[1]|anon[0]" class="facebook">FACEBOOK</span>
                <span data-omni-action="google|sid[8|22|37]|slider[1]|anon[0]" class="google">GOOGLE +</span>
                <span data-omni-action="twitter|sid[8|22|37]|slider[1]|anon[0]" class="twitter">TWITTER</span>
                <span data-omni-action="yahoo|sid[8|22|37]|slider[1]|anon[0]" class="yahoo">YAHOO!</span>
            </div>
            <div class="line"> </div>
            <div class="footer">
                <p>
                    Don't have an account yet?
                    <span class="mvn-join-button">Sign Up &rsaquo;</span>
                </p>
                            </div>
        </div>
        <script type="text/javascript">
            $(function(){
                $('#login').on('submit', function(e){
                    $('#login-error').hide();
                    e.preventDefault();
                    var formData = $('#login').serialize();
                    MVN.sso.authUser(formData, function(resp){
                        $.ajax({
                            url: '/profile/authUser',
                            method: 'post',
                            data: formData,
                            success: function(){
                                window.MVN.user = resp.user;
                                location.reload();
                                $.modal.close();
                            }
                        });

                    }, function(e){
                        $('#login-error').html(e.message.error).show();
                    });
                });
                $('#forgot').click(function(){
                    $.ajax({
                        url: '/profile/ajaxForgot',
                        method: 'get'
                    }).done(function(d){
                        $('#login-modal').html(d);
                    })
                })
            });
            function social(network){
                if(ssoWindow)
                    ssoWindow.close();
                var winArr = ['status=0', 'toolbar=0', 'location=0', 'menubar=0', 'resizable=0', 'scrollbars=1'],
                    winW, winH;
                switch(network){
                    case 'yahoo':
                        winW = 500;
                        winH = 525
                        break;
                    case 'google':
                        winW = 875;
                        winH = 500;
                        break;
                    case 'twitter':
                        winW = 620;
                        winH = 675;
                        break;
                    case 'facebook':
                        winW = 640;
                        winH = 350;
                        break;
                    default:
                        return;
                }
                winArr.push('width='+winW, 'height='+winH);
                ssoWindow = window.open('/done.html', 'mvnSsoWin', winArr);
                ssoWindow.blur();
                if(navigator.userAgent.match(/iPad/i) != null){
                    window.parent.focus();
                }
            }
            if (typeof document.createElement("input").placeholder === 'undefined') {
                $(document.body).on('focus', 'input[placeholder]', function () {
                    if (this.value == $(this).attr('placeholder')) {
                        this.value = '';
                    }
                    $(this).removeClass('placeholder');
                }).on('blur', 'input[placeholder]', function () {
                    if (this.value == '') {
                        this.value = $(this).attr('placeholder');
                        $(this).addClass('placeholder');
                    } else {
                        $(this).removeClass('placeholder');
                    }
                });
                $('input[placeholder]').blur();
            }

            $('[data-omni-action]').on('click', function(){
                var call = $(this).data('omni-action');
                var action = call.split('|').slice(0,1).toString();
                switch(action){
                    case 'facebook':
                    case 'twitter':
                    case 'yahoo':
                    case 'google':
                        MVN_Server.client.action(call);
                        social(action);
                        break;
                    case 'anon':
                        MVN_Server.client.handleResponse({'status':'success', 'anon':true});
                        break;
                    default:
                        MVN_Server.client.action(call);
                        break;
                }
            });
            // updateModal();
        </script>        <style type="text/css">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</style>
        <div class="main-container" id='join-modal'>
        <span class="omni-icon-close"></span>
        <div id="join-step1">
            <div class="intro">
                <h1>Connect. Discover. Share.</h1>
                                <img title="Connect. Discover. Share." src="/img/mvn/1.jpg"/>
                                <p>
                    Get the most out of your experience with a personalized all-access pass to everything local on events, music, restaurants, news and more.
                </p>
            </div>
            <div class="line"></div>
            <p class="social">Enter your email or sign up with a social account to get started</p>
            <div id="social">
                <span data-omni-action="facebook|sid[8|22|37]|slider[1]|anon[0]" class="facebook">FACEBOOK</span>
                <span data-omni-action="twitter|sid[8|22|37]|slider[1]|anon[0]" class="twitter">TWITTER</span>
                <span data-omni-action="google|sid[8|22|37]|slider[1]|anon[0]" class="google">GOOGLE+</span>
                <span data-omni-action="yahoo|sid[8|22|37]|slider[1]|anon[0]" class="yahoo">YAHOO!</span>
            </div>
            <div class="login">
                <p class="error" id="join-error"></p>
                <form id="join" method="post">
                    <input type="text" placeholder="Enter Your Email" id="join-email" name="email">
                    <input type="hidden" value="hou" name="cid"/>
                    <input type="hidden" value="8|22|37" name="sid"/>
                    <div id="captcha">
                        <div id="join-recaptcha" data-key="6LcMCwgTAAAAAM86pPA6G1eIFDlL7iaeT3Y81A0Q"></div>
                    </div>
                    <a href="/about/privacyPolicy/" target="_top">Privacy Policy</a>
                    <button type="submit" >SIGN UP &rsaquo;</button>

                </form>
            </div>
            <div class="footer">
                <p>Already registered? <span class="mvn-login-button">Login &rsaquo;</span></p>
            </div>
        </div>
        <div id="join-step2">
        <style type="text/css">
    #demo {
        font: 12px/15px Arial,Verdana,sans-serif;
        margin: 0;
        padding: 0;
        overflow: hidden;
        background: transparent;
        max-width: 400px;
    }
    #demo a {
        cursor: pointer;
        color: #e40001;
        text-decoration: none;
    }
    #demo a:hover {
        text-decoration: underline;
    }
    #demo p {
        margin: 10px 0 0;
    }
    #demo p.error {
        color: red;
        background-color: #D6D6D6;
        padding: 3px 5px;
        clear: both;
        font-weight: bold;
        font-size: 12px;
        text-align: left;
    }
    #demo p.error:before {
        content: "\00D7";
        padding: 0 10px 0 5px;
    }
    #modal-demofields {
        margin: 0;
        padding: 0;
        display: inline-block;
    }
    #modal-demofields > ul {
        text-align: right;
        list-style-type: none;
        margin: auto 5px;
        padding: 0;
        display: block;
    }
    #modal-demofields > ul > li {
        float: left;
        padding-top: 10px;
        display: list-item;
    }
    #modal-demofields > ul > li label{
        clear: left;
        display: block;
        float: left;
        margin-right: 15px;
        padding-top: 5px;
        text-align: right;
        font: normal 14px/15px avalonWeb, sans-serif;
    }
    #modal-demofields > ul > li label > span{
        font-size: 16px;
        font-weight: bold;
        margin-right: 2px;
    }
    #modal-demofields > ul > li input[type=text],
    #modal-demofields > ul > li input[type=password]{
        clear: right;
        margin-bottom: 15px;
        width: calc(100% - 100px);
        border: 1px solid #444444;
        padding: 5px;
    }
    #modal-demofields > ul > li input[type=text].half {
        width: calc(50% - 52px);
    }
    #modal-demofields > ul > li input[type=image]{
        height: 24px;
    }
    #demo span#loading span {
        position: absolute;
        top: 0;
        left: 0;
        width: 100%;
        height: 100%;
    }
    #demo span#loading span.trans-50 {
        filter: alpha(opacity=50);
        -moz-opacity:0.5;
        -khtml-opacity: 0.5;
        opacity: 0.5;
        background-color: white;
    }
    #demo span#loading > span + span {
        background: url("/img/modal_spin_black.gif") no-repeat center center transparent;
    }
    #demo button {
        font: normal 14px/15px avalonWeb, sans-serif;
        display: block;
        width: 180px;
        background-color: #666;
        margin: 8px auto;
        color: white;
        border: none;
        cursor: pointer;
        text-align: center;
    }
    #modal-demoError{
        display:none;
    }
</style>
<div id="demo">
<form id="modal-demofields" method="post">
    <ul>
        <li>
            <div id="modal-demoError"></div>
            <label>*Email</label>
            <input type="text" id="modal-demofields-email" name="email" readonly="readonly" value="" disabled="disabled"/><br/>
            <input type="hidden" name="uid" id="modal-demofields-uid"/>
            <label for="username">*Username</label>
            <input type="text" id="modal-demofields-username" name="username" value="" maxlength="20"/><br/>
            <label for="password">*Password</label>
            <input type="password" id="modal-demofields-password" name="password" maxlength="64"/><br/>
            <label for="name">Name</label>
            <input type="text" id="modal-demofields-fname" name="f_name" placeholder="first name" value="" maxlength="45" class="half"/>
            <input type="text" id="modal-demofields-lname" name="l_name" placeholder="last name" value="" maxlength="45" class="half"/><br/>
            <label for="zipcode">*Zipcode</label>
            <input type="text" id="modal-demofields-zipcode" name="zipcode" value="" maxlength="5"/>
            <button type="submit">DONE</button>
        </li>
    </ul>
</form>
</div>
<script type="text/javascript">
	$(function(){
		window.MVN.queue(function(){
			if (typeof window.MVN.user !== 'undefined'){
				$.ajax({
					url: '/profile/ajaxRequestFullUser',
					data: {uid: window.MVN.user.id},
					method: 'POST',
					success: function(r){
						var user = r.data;
						$('#modal-demofields-uid').val(user.User.id);
						$('#modal-demofields-email').val(user.User.email);
						$('#modal-demofields-username').val(user.User.username);
						$('#modal-demofields-fname').val(user.UserDemographic.f_name);
						$('#modal-demofields-lname').val(user.UserDemographic.l_name);
						$('#modal-demofields-zipcode').val(user.UserDemographic.zipcode);
					}
				});
			}
			$('#modal-demofields').submit(function(e){
				e.preventDefault();
                $('#modal-demofields-email').attr('disabled', false);
				var formfields = $('#modal-demofields').serialize();
				MVN.sso.settings(formfields, function(r){
                    $.ajax({
                        url: '/profile/regSailThru',
                        data: formfields,
                        method: 'post'
                    }).success(function(e){
                        $('#modal-demoError').text('Registration is complete!').show();
                        $.modal.close();
                        window.location = "http://"+window.location.hostname+"/music/last-night-peter-frampton-at-the-woodlands-pavilion-11358487";
                    })
				}, function(r){
                    $('#modal-demoError').text('There was a problem with your information. Please check it and try again').show();
				})
			})
		})
	});
</script>        </div>
        </div>
        <script type="text/javascript">
            $(function(){
                VMG.captchaQueue.queue(function(){
                    grecaptcha.render('join-recaptcha',{
                        'sitekey' : $('#join-recaptcha').data('key')
                    })
                })
                $('#join-modal').on('click', '.omni-icon-close', function(){
                    $.modal.close();
                })
                $('#join-modal').on('focus', '#join-email',function(){
                    $('#captcha').show();
                });
                $('#join').submit(function(e){
                    $('#join-error').hide();
                    e.preventDefault();
                    var formData = $('#join').serialize();
                    MVN.sso.authUser(formData, function(r){
                        $.ajax({
                            url: '/profile/authUser',
                            method: 'post',
                            data: formData
                        });
                        $('#join-step1').toggle();
                        $('#join-step2').toggle();
                        $('.omni-icon-close').toggle();
                        window.MVN.user = r.user;
                        $('#modal-demofields-uid').val(r.user.id);
                        $('#modal-demofields-email').val(r.user.email);
                        $('#modal-demofields-username').val(r.user.username);
                        // location.reload();
                        // $.modal.close();
                    }, function(r){
                        $('#join-error').html(r.message.error).show();
                    });
                });
            })
        </script>

<script type="text/javascript">
	$(function(){
		$(".mvn-login-button").click(function(){
			$.modal.close();
			$("#login-modal").modal({focus: false});
		});
		$(".mvn-join-button").click(function(){
			$.modal.close();
			$("#join-modal").modal({focus: false});
		});
	});
</script>

<li class="mvn ">
    <a class="sprite trigger" title="Connect. Discover. Share.">MVN</a>
    <div class="drop drop-mvn">
        <span class="mvn-login-button">Sign In &rsaquo;</span>
        <p>Don't have an account yet?</p>
        <span class="mvn-join-button">Sign Up &rsaquo;</span>
    </div>
    </li>                <li class="fb" title="follow us on Facebook"><a class="sprite trigger" href="https://www.facebook.com/HoustonPress" onClick="ga('send', 'event', 'Sticky-Bar', 'Click', 'Facebook',  {'NonInteraction': 1});" target="_blank">Facebook</a></li>
                        <li class="tw" title="follow us on Twitter">
            <a class="sprite trigger" href="https://twitter.com/houstonpress" onClick="ga('send', 'event', 'Sticky-Bar', 'Click', 'Twitter',  {'NonInteraction': 1});" target="_blank">Twitter</a>
        </li>
                        <li class="ig" title="follow us on Instagram">
            <a class="sprite trigger" href="http://instagram.com/houstonpress" onClick="ga('send', 'event', 'Sticky-Bar', 'Click', 'Instagram',  {'NonInteraction': 1});" target="_blank">Instagram</a>
        </li>
            </ul>
                        <!-- <progress id="article-progress" value="0" max="90"></progress> -->

                    </div><!-- /.masthead -->

                </div><!-- /.sde-shadow -->

                <div class="content">
                    <div class="ads top" data-vmg-ad="Top" id="appnexus-ANLBTop" data-pos="above" data-vmg-format="normal"></div>                    <div id="stickyRail">
                        <div class="ads middle1" data-vmg-ad="Middle1" id="appnexus-ANRectangleTop" data-refresh-ad="1" data-pos="unknown" data-vmg-format="normal"></div><div class="ads middle1" data-vmg-ad="Middle1" id="appnexus-ANRectangleTop" data-refresh-ad="1" data-pos="unknown" data-vmg-format="normal"></div>                            <div class="rail-rec">
    <h2>Recommended For You</h2>
    <ul>
            <li>
        <a href="/music/things-to-do-squeeze-warehouse-live-september-18-2019-11351403">
            Squeeze's Chris Difford on Those Lennon-McCartney Comparisons: "I'm Ringo"        </a>
        </li>
            <li>
        <a href="/music/tobe-nwigwe-leads-a-panel-t-mfah-11354160">
            10 Things We Learned from #TobeNwigweAtMFAH        </a>
        </li>
        </ul>
</div><!-- /.rail-rec -->
                            <div class="ads middle" data-vmg-ad="Middle" id="appnexus-ANRectangle" data-pos="below" data-vmg-format="normal"></div>
                                                    <div id="subSticky" class="side-sub">
                            <ul id="playlist">
                            <li class="current"><div class="meter" style="width: 0%;"></div><div id="sub11358487" class="hed"><a href="/music/last-night-peter-frampton-at-the-woodlands-pavilion-11358487">Peter Frampton Says Goodbye to Houston in Powerful and Joyous Farewell Tour</a></div></li>
                            </ul>
                            <div class="ads rotatingrectangle" data-vmg-ad="rotatingrectangle" id="appnexus-ANRotatingRectangle" data-refresh-ad="true" data-pos="unknown" data-vmg-format="normal"></div>                            <div id="wbtz-placeholder"><div class="wbtz-box" id="wbtz-rail" wibbitz="embed-player-widget"></div></div>
                        </div><!-- /#subSticky -->
                    </div><!-- /#stickyRail -->
                    
<section class="content-view" id="objid11358487" data-feed-only="true" data-st-customerid="e902d43c3b6fd1755d277bec05facac6" data-st-section="cafdb936-b2bf-11e7-a974-002590d1a2f6">
    <div class="schema">
        <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="http://www.houstonpress.com/music/last-night-peter-frampton-at-the-woodlands-pavilion-11358487">
        <meta itemprop="name" content="Peter Frampton Says Goodbye to Houston in Powerful and Joyous Farewell Tour">
        <meta itemprop="datePublished" content="2019-09-22 06:41:00">
        <meta itemprop="dateModified" content="2019-09-22 07:13:43">
        <span itemprop="author" itemscope itemtype="http://schema.org/Person">
            <span itemprop="name">Bob Ruggiero</span>
        </span>
        <div itemprop="publisher" itemscope itemtype="http://schema.org/Organization">
            <meta itemprop="name" content="Houston Press">4
            <div itemprop="logo" itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop="url" content="https://www.houstonpress.com/theme/hou/img/logo-150.png">
            </div>
            <meta itemprop="url" content="https://www.houstonpress.com">

        </div>
    </div>

    <div class="the-story">
        <div class="img-box bulge first-image ">
<div class="inner-img-box">
<img src="https://images1.houstonpress.com/imager/u/745xauto/11358491/hou_mus_frampton2.jpg" alt="Peter Frampton energizes the audience at The Woodlands."><a class="expand-link sprite" href="https://images1.houstonpress.com/imager/u/original/11358491/hou_mus_frampton2.jpg" target="_blank" title="CLICK FOR FULL SIZE">EXPAND</a><div class="insert cap-cred">
<div class="cap">Peter Frampton energizes the audience at The Woodlands.</div>
<div class="cred">Photo by David Wright</div>
</div>
</div>
<!-- /.inner-img-box -->
</div>

    <h1>Peter Frampton Says Goodbye to Houston in Powerful and Joyous Farewell Tour</h1>
    <div class="article-info ">
        <div class="by-auth">
            <span class="byline"><a href="/authors/bob-ruggiero-6356364">Bob Ruggiero</a></span> | <span class="pubdate">September 22, 2019</span> | <span class="pubdate">6:41am</span>
        </div><!-- /.by-auth -->
    </div><!-- /.article-info -->
    <div class="cs-box side-soc">
    <ul class="socials ai-socials">
                <li class="fb" title="Share this on Facebook"><a class="sprite share" target="_blank" data-popularity-track="Social">Facebook</a></li>

        <li class="tw" title="Share this on Twitter">
            <a class="sprite share" target="_blank" data-popularity-track="Social">Twitter</a>
        </li>
        <li class="com" title="Leave a comment"><a class="sprite fb-com" data-objid="11358487" data-header="Peter Frampton Says Goodbye to Houston in Powerful and Joyous Farewell Tour" href="javascript:;"></a><div class="count" data-href="http://www.houstonpress.com/music/last-night-peter-frampton-at-the-woodlands-pavilion-11358487"></div></li>

        <li class="em"><a class="sprite share" target="_blank" href="mailto:?subject=HoustonPress.com%3A+Peter+Frampton+Says+Goodbye+to+Houston+in+Powerful+and+Joyous+Farewell+Tour&amp;body=http%3A%2F%2Fwww.houstonpress.com%2Fmusic%2Flast-night-peter-frampton-at-the-woodlands-pavilion-11358487">email</a></li>
        <li class="prnt" title="Print this article"><a class="sprite print" href="/content/printView/11358487" target="_blank">Print Article</a></li>
    </ul>

    <div class="text-size" title="Toggle text size">
        <span>A</span>A
    </div>
</div>
    <div class="story-body"><div class="ads middleleaderboard placeholder" data-vmg-ad="MiddleLeaderboard" id="appnexus-ANLBMiddle" data-pos="unknown" data-vmg-format="lazy"></div><p>While Peter Frampton has joined the long (and getting longer) list of classic rock-era acts who have decided to put an end to extended touring, in his case it doesn&rsquo;t stem from any desire to actually leave the stage. </p><p>In February, Frampton announced that he has a degenerative muscular disease called inclusion body myositis. And while it does not shorten life expectancy, it will mean that he will have less and less control over muscles in his arm and hands (not a great diagnosis for a guitar player) and legs. </p><p>That&rsquo;s why he&rsquo;s been furiously recording new music in his Nashville home studio to roll out over the years. The first record, <i>All Blues</i>, came out in June and has spent as of now 11 weeks on the top of the Billboard Blues Album chart. He&rsquo;s also embarked on this tour he&rsquo;s calling Finale &ndash; The Farewell Tour (if you didn&rsquo;t get the meaning with the first F word). The Houston show was No. 39 on the list of 51 scheduled dates.</p><div id="ym_927391772937231496" class="ads centered yieldmo ym" data-vmg-ad="Yieldmo" data-yieldmo-id="927391772937231496"></div><p>Opening the evening was Jason Bonham&rsquo;s Led Zeppelin Evening, with a 50-minute set featuring many of that band&rsquo;s best known and loved tunes. No one was more excited than Bonham to play the 2007 &ldquo;Celebration Day&rdquo; concert with his late dad&rsquo;s surviving mates in Zep. And no one was more disappointed when three of them (Bonham, Jimmy Page, and John Paul Jones) wanted to take the show on the road and one of them (Robert Plant) didn&rsquo;t, nixing the whole thing.&nbsp; </p><div class="img-box middle-size ">
<div class="inner-img-box">
<img src="https://images1.houstonpress.com/imager/u/blog/11358493/hou_mus_bonhamzep.jpg" alt="Jason Bonham's Led Zeppelin Evening"><div class="insert cap-cred">
<div class="cap">Jason Bonham's Led Zeppelin Evening</div>
<div class="cred">Photo by David Wright</div>
</div>
</div>
<!-- /.inner-img-box -->
</div><p>Bonham&rsquo;s group began as a one-off tribute to his father, but has become its own entity for a number of years. And while he&rsquo;s every bit the monster drummer his father was (and maybe with even with a bit more technique), he was not well served by the rest of the band. </p><span class="inline-video" data-vmg-ad="Teads" data-vmg-track="2nd ad"></span><script type="text/javascript">
$(function(){
var pidChange;
var site_pathname = window.top.location.pathname;
if (site_pathname.match(/restaurants/g)) {
  pidChange = 45248;
} else if (site_pathname.match(/film/g)) {
  pidChange = 45247;
} else if (site_pathname.match(/news/g)) {
  pidChange = 45246;
} else if (site_pathname.match(/music/g)) {
  pidChange = 45245;
} else if (site_pathname.match(/arts/g)) {
  pidChange = 45244;
} else {
  pidChange = 42586;
}

window._ttf = window._ttf || [];
(function (d, p) {
    var js, s = d.getElementsByTagName('script')[0];
    js = d.createElement('script'); js.async = true; js.defer = true;
    js.src = '//a.teads.tv/page/' + p + '/tag';
    s.parentNode.insertBefore(js, s);
})(window.document, pidChange);
});
</script><p>Bonham&rsquo;s own website doesn&rsquo;t list his band members&rsquo; names, so we&rsquo;ll go with their roles. The singer was more aggro-metal, lacked charisma, and seemed to recite lyrics rather than invest in them. The guitarist had Jimmy Page&rsquo;s look and stage stance, but none of his fluidity. And the bassist was so buried in the mix, he might was well have not been on stage. Only &ldquo;Good Times Bad Times&rdquo; and &ldquo;Ramble On&rdquo; stood out, though there was in inherent power for the finale just hearing &ldquo;Stairway to Heaven&rdquo; live.</p><p>When Peter Frampton took the stage, he must have been nearly knocked over by the positive vibes and goodwill this Houston audience sent his way immediately. And no classic rocker regularly and honestly shows as much palpable joy in performing as he does.</p><p>In a career-spanning set just over two hours, highlights included an elegant (and, considering Frampton&rsquo;s situation, fairly touching) &ldquo;Lines on My Face,&rdquo; which also served as a tribute to late band members Bob Mayo and John Siomos. Deep cut &ldquo;The Lodger&rdquo; (inspired by Frampton&rsquo;s party house while a member of Humble Pie) was a wonderful surprise preceded by a humorous story. And warhorse &ldquo;Show Me The Way,&rdquo; was the first of several audience sing-alongs.</p><div class="img-box ">
<div class="inner-img-box">
<img src="https://images1.houstonpress.com/imager/u/745xauto/11358492/hou_mus_frampton1.jpg" alt="Peter Frampton says goodbye to Houston on stage and on a large screen."><a class="expand-link sprite" href="https://images1.houstonpress.com/imager/u/original/11358492/hou_mus_frampton1.jpg" target="_blank" title="CLICK FOR FULL SIZE">EXPAND</a><div class="insert cap-cred">
<div class="cap">Peter Frampton says goodbye to Houston on stage and on a large screen.</div>
<div class="cred">Photo by David Wright</div>
</div>
</div>
<!-- /.inner-img-box -->
</div><p>A surprisingly hot bluesy cover of &ldquo;Georgia on My Mind&rdquo; and boastful, rocking version of Freddie King&rsquo;s &ldquo;Me and My Guitar&rdquo; (both from <i>All Blues</i>) anchored the middle of the set. And while his mostly-instrumental cover of Soundgarden&rsquo;s &ldquo;Black Hole Sun&rdquo; has been a set highlight since he recorded it for 2006&rsquo;s Fingerprints, it&rsquo;s taken on more resonance since the suicide of that band&rsquo;s singer Chris Cornell. </p><div class="ads middle" data-vmg-ad="Middle" id="appnexus-ANRectangle" data-pos="below" data-vmg-format="normal"></div><p>In just one of many effective uses of the large video screen throughout the night, animation of a cosmic journey in a twisting tunnel turned hundreds of points of light into Cornell&rsquo;s own visage by the end of the song. </p><p>Set closer &ldquo;Do You Feel Like We Do?&rdquo; was a powerful and joyous romp, but the two Humble Pie songs that made up part of the encore (&ldquo;Four Day Creep,&rdquo; &ldquo;I Don&rsquo;t Need No Doctor&rdquo;) were heavy blasts of pure rock energy. And it was another effective use of the video screen &ndash; this time showing images of that band and its late leader Steve Marriott.&nbsp; </p><div class="img-box middle-size ">
<div class="inner-img-box">
<img src="https://images1.houstonpress.com/imager/u/blog/11358494/hou_mus_frampton3.jpg" alt="Peter Frampton joked that he ditched the jacket he was wearing at the start of the show due to the Houston heat."><div class="insert cap-cred">
<div class="cap">Peter Frampton joked that he ditched the jacket he was wearing at the start of the show due to the Houston heat.</div>
<div class="cred">Photo by David Wright</div>
</div>
</div>
<!-- /.inner-img-box -->
</div><p>There were a couple of weak spots. Set opener &ldquo;Baby (Somethin&rsquo;s Happening)&rdquo; kind of limped the band in, and the lengthy guitar duel during &ldquo;(I&rsquo;ll Give You) Money&rdquo; long overstayed its welcome &ndash; no matter the talent of Frampton and second guitarist Adam Lester. The rest of the group &ndash; Rob Arthur (keyboards/vocals), Dan Wojciechowski (drums) and Steve Mackey (bass) gelled well, with Arthur&rsquo;s keyboard work (especially on &ldquo;Do You Feel Like We Do?&rdquo;) a highlight.</p><p>During the show, Frampton took a little time to reminisce specifically about Houston. Like how in the &lsquo;70s at one point his entire road crew was from the city. Also, that one of his former production manager was now one of the honchos running The Woodlands Pavilion.</p>
<div class="vmgs widget subscribe" id="sub-id-11358487" data-vmgs-widget="subscribe">
    <div class="innards">
        <h3 data-vmgs-element="welcome-header">If you like this story, consider signing up for our email newsletters.</h3>
        <h4 class="sub-action city-color-variants-1-back">SHOW ME HOW</h4>
        <div class="hidey city-color-variants-1-back">
            <div class="close">X</div><!-- /.close -->
            <div class="welcome">
                <img src="/theme/hou/img/logo-white.png" class="bwlogo" title="Houston Press" alt=""/>                <h5>Newsletters</h5>
            </div><!-- /.welcome -->
            <form id="subscribe11358487">
            <div class="signup">
                <ul id="subscribe-11358487" class="options">
                </ul>
                <sub>All-access pass to the top stories, events and offers around town.</sub>
            </div><!-- /.signup -->
            <div class="captcha-container" data-vmgs-element="recaptcha" data-vmgs-action-expand="show" data-vmgs-action-collapse="hide">
                <div id="inarticle-captcha11358487" class="g-recaptcha" data-sitekey="6LcMCwgTAAAAAM86pPA6G1eIFDlL7iaeT3Y81A0Q"></div><!-- /.g-recaptcha -->
            </div><!-- /.captcha-container -->
            <div class="inputs">
                <input type="text" name="email" class="email" data-vmgs-element="email" placeholder="name@mail.com" tabindex="3">
                <input type="hidden" name="source_primary" value="8">
                <input type="hidden" name="source_sub" value="49">
                <ul class="buttons">
                    <li class="bttn nt"><a href="javascript:;" class="button nothanks city-color-variants-1-back" data-vmgs-element="cancel" tabindex="2">No Thanks</a></li>
                    <li class="bttn su"><a href="javascript:;" class="button" data-vmgs-element="submit" tabindex="4">Sign Up</a></li>
                </ul>
            </div><!-- /.inputs -->
            </form>
            <div data-vmgs-element="errors" data-vmgs-action-collapse="hide" class="error" style="display: none;"></div>
        </div> <!-- /.hidey -->
        <div class="hidey success city-color-variants-1-back" style="display: none;">
            <div class="close">X</div>
            <h2>SUCCESS!</h2>
            <p>You have successfully signed up for your selected newsletter(s) - please keep an eye on your mailbox, we're movin' in!</p>
        </div><!-- /.hidey.success -->
    </div><!-- /.innards -->
</div><!-- /.vmgs.widget.subscribe -->

        <script type="text/javascript">
            $(function(){
                if (typeof VMGSConfig == 'undefined') {
                    VMGSConfig = {};
                }
                VMGSConfig.CityId      = 'hou';
                VMGSConfig.MvnHostname = '';
                VMG.captchaQueue.queue(function(){
                    grecaptcha.render('inarticle-captcha11358487',{
                        'sitekey' : $('#inarticle-captcha11358487').data('sitekey')
                    })
                })

                $.ajax({
                url         : '/profile/ajaxRequestSectionSubs',
                data        : VMG.Ads.query,
                dataType    : 'json',
                type        : 'POST',
                success     : _.bind(function(json, textStatus, jqXHR)
                {
                    var weekly = [];
                    _.each(json.data, function(sub)
                    {
                        if (VMG.hasDailyNL && (sub[0] == 'weekly' || sub[0] == 'daily')){
                            weekly.push(sub);
                        } else {
                            var name = sub[0].charAt(0).toUpperCase() + sub[0].substr(1).replace('_', ' ');
                            $('#subscribe-11358487').prepend(
                                $('<li><input type="checkbox" id="'+sub[0]+'-11358487" name="subs[]" checked value="'+sub+'" /><label for="'+sub[0]+'-11358487">'+name+'</li>')
                            );
                        }
                    }, this);
                    if (weekly.length !== 0){
                        $('#subscribe-11358487').append('<li class="double"></li>');
                        _.each(weekly, function(sub){
                            var id = sub[1];
                            var name = sub[0].charAt(0).toUpperCase() + sub[0].substr(1).replace('_', ' ');
                            $('#subscribe-11358487 li.double').append(
                                $('<input type="checkbox" name="subs[]" id="'+sub[0]+'-11358487" value="'+sub+'" /><label for="'+sub[0]+'-11358487">'+name+'</label>')
                            )
                        });
                        if (window.VMG.Utils.getCity() == 'mia'){
                            $('#daily-11358487').attr('checked', true);
                        } else {
                            $('#weekly-11358487').attr('checked', true);
                        }
                    }
                    var category = VMG.Ads.query.match(/Category=([^\&]*)/)[1];

                    $('#subscribe11358487 .su .button').click(function(e)
                    {
                        $('#sub-id-11358487 .error').hide();
                        e.preventDefault();
                        var subData = $('#subscribe11358487').serialize() + '&category='+category;
                        $.ajax({
                            url        : '/profile/subscribe',
                            data       : subData,
                            dataType   : 'json',
                            type       : 'POST',
                            complete      : function(data){
                                var response = data.responseJSON;
                                if (!response.ok){
                                    var errorOutput = '';
                                    $(response.errors).each(function(k,v){
                                        if (k == 0){
                                            errorOutput += v;
                                        } else {
                                            errorOutput += ','+v;
                                        }
                                        $('#sub-id-11358487 .error').html(errorOutput);
                                        $('#sub-id-11358487 .error').show();
                                    });
                                } else {
                                    $('#sub-id-11358487 .hidey').hide();
                                    $('#sub-id-11358487 .success').show();
                                    if (typeof ga == "function") {
                                        ga('send', 'event', 'InArticleSubscribe', 'Click', 'Subscribed');
                                    }
                                }
                            }
                        });
                    });
                }, this),
                error : _.bind(function(jqXHR, textStatus)
                {
                    console.log('modal subscriptions lookup failed:', {
                        jqXHR      : jqXHR,
                        textStatus : textStatus
                    });
                }, this)
            });
            });
        </script><div class="ads middle" data-vmg-ad="Middle" id="appnexus-ANRectangle" data-pos="below" data-vmg-format="normal"></div><p>Knowing that this was likely Frampton&rsquo;s final stop in Houston gave the evening and extra tinge of both celebration and melancholy. And while Frampton has said in a recent interview that he felt his disease had affected his playing ever since he started this tour, that evidence was utterly lacking on this night. And throughout, his distinctive voice showed little wear and tear over time, sounding extremely close to the records he made some four-plus decades ago.</p><p>A raconteur willing to poke fun at himself and a showman who seems to truly appreciate his audience, the now 69-year-old Peter Frampton will be missed on the summer classic rock tour schedule. And that&rsquo;s why it&rsquo;s important to see these acts of the &lsquo;60s and &lsquo;70s now because &ndash; not to sound morbid &ndash; there may not be a next time. And Peter Frampton &ndash; truly a class act &ndash; left the Houston stage with his head high, his guitar fairly smoking, and his reputation only buoyed.</p><p><b>Set List</b><br> Baby (Somethin&rsquo;s Happening)<br> Lying<br> Lines on My Face<br> Show Me the Way<br> The Lodger<br> Georgia (On My Mind)<br> Me and My Guitar<br> Same Old Blues<br> Breaking All the Rules<br> Black Hole Sun<br> (I&rsquo;ll Give You) Money<br> Baby, I Love Your Way<br> Do You Feel Like We Do?</p><p><i>encore</i><br> Four Day Creep<br> I Don&rsquo;t Need No Doctor<br> While My Guitar Gently Weeps</p>    
    <ul class="topics">
    <li><a class="city-color-back" href="/topic/classic-rock-corner-6362198">Classic Rock Corner</a></li>
    <li><a class="city-color-back" href="/topic/concerts-6362276">Concerts</a></li>
    <li><a class="city-color-back" href="/topic/history-7372477">History</a></li>
    <li><a class="city-color-back" href="/topic/music-6362322">Music</a></li>
    <li><a class="city-color-back" href="/topic/rock-6362229">Rock</a></li>
    </ul>

<div class="article-footer">
          <div class="authorPicBox">
                    <div class="authorPic"><a href="/authors/bob-ruggiero-6356364" style="background: transparent url('https://images.houstonpress.com/imager/b/mobilesquare/6356364/5c0b/bobruggieronewpiccrop.jpg') no-repeat center center;">&nbsp;</a>
            </div>
              </div>
    
    <div class="authorInfo">
                    <div class="bio"><b>Bob Ruggiero</b> has been writing about music, books, and entertainment for the <i>Houston Press</i> since 1997, with an emphasis on classic rock. He used to have an incredible and luxurious mullet in college as well. He is the author of the band biography <i>Slippin’ Out of Darkness: The Story of WAR.</i></div>
                <ul class="follows">
        <!-- author -->
                                                        </ul><ul class="follows">
                    
                    
                    
                    
                            

        </ul>
    </div>

</div><!-- /.article-footer -->

</div><!-- /.story-body -->    </div><!-- /.the-story -->
    

    <div class="bottomBlock">
    <div class="bottom-lists">
        <div class="bottom-list relaround">
                <h2>Trending Music</h2>
    <div class="st-load unblur" id="Article-SPM-Music-Recommended-11358487" data-st-customerid="e902d43c3b6fd1755d277bec05facac6" data-st-section="8a469086-a12f-11e6-88be-002590d1a41a">
        <ul>
                    <li>
            <a class="city-color.redux" data-st-field="title" href="/music/things-to-do-luba-dvorak-plays-big-top-lounge-every-wednesday-11351400">Brooklyn Twang:  Luba Dvorak Delivers Quality Honky Tonk On...</a>
            </li>
                    <li>
            <a class="city-color.redux" data-st-field="title" href="/music/things-to-do-houstons-best-concerts-for-the-week-of-9-18-2019-11354709">Houston Concert Watch: 9/18: Morrissey and More</a>
            </li>
                    <li>
            <a class="city-color.redux" data-st-field="title" href="/music/thing-to-do-styx-at-the-smart-financial-centre-11353094">Styx Continue Their "Mission" into the Future</a>
            </li>
                    <li>
            <a class="city-color.redux" data-st-field="title" href="/music/things-to-do-houstons-best-concerts-for-the-week-of-9-11-2019-11351163">Houston Concert Watch 9/11: The National and More</a>
            </li>
                </ul>
        <h4 class="pbst">Powered by SailThru</h4>
    </div>
        </div><!-- /.bottom-list.relaround -->
                <div class="ads middle" data-vmg-ad="Middle" id="appnexus-ANRectangle" data-pos="below" data-vmg-format="normal"></div>                <div class="adbox">
        </div><!-- /.bottom-list.tmaster -->
    </div><!-- /.bottom-lists -->

    
</div><!--- /.bottomBlock -->

    <div id="comments" class="comments">
    <div id="fb-comment-data-11358487"
        data-href="http://www.houstonpress.com/music/last-night-peter-frampton-at-the-woodlands-pavilion-11358487"
        data-width="100%"
        data-numposts="5"
        data-colorscheme="light">
    </div>
</div>
    <script type="text/javascript">
        var thisSection = "#objid11358487";
        var stickyBreakpoint = 768;
        var numStories = $(".content-view").length;
        if(typeof $().stick_in_parent != 'undefined' && window.innerWidth >= stickyBreakpoint) {
            $(thisSection + " .cs-box").stick_in_parent({
                offset_top: 70,
            });
        }
        $(thisSection + " .text-size").click(function() {
            $(thisSection + " .the-story > p, " + thisSection + " .the-story > .mobile-fold > p").toggleClass("bigger");
        });

        $(thisSection).addClass("cv" + numStories);
    </script>
    <div class="ads articlemiddleleaderboard" data-vmg-ad="ArticleMiddleLeaderboard" id="appnexus-ANLBMiddle" data-pos="unknown" data-vmg-format="normal"></div>
</section><!-- /.content-view -->




<!-- next article load here, include .content-view section -->




<script type="text/javascript" src="//cdn4.wibbitz.com/houston_press/embed.js" async></script>
                </div><!-- /.content -->

                <div id="vmgInterstitial"><div class="ads bottomsticky" data-vmg-ad="bottomsticky" id="appnexus-ANSticky" data-refresh-ad="1" data-pos="unknown" data-vmg-format="normal"></div></div>
                <div class="footer">

    <div class="ads bottom" data-vmg-ad="Bottom" id="appnexus-ANLBBottom" data-pos="below" data-vmg-format="normal"></div>
    <p>Use of this website constitutes acceptance of our <a href="/about/terms-of-use">terms of use</a>, our <a href="/about/cookies">cookies policy</a>, and our <a href="/about/privacy-policy">privacy policy</a>
    <p>&copy;2019 Houston Press, LP. All rights reserved.</p>

</div>
<script type='text/javascript' data-sailthru-setup="true" src='https://ak.sail-horizon.com/spm/spm.v1.min.js'></script>

<script type='text/javascript'>
	VMG.Components.Adblock = true;
	$(function(){
	    VMG.cityData = {"objid":"808579","creationdate":"2008-06-24 17:47:37","lastmodified":"2019-09-22 07:25:05","Name":"Houston Press","Publication":"hou","Domain":"houstonpress.com","PublicationCity":"Houston","Title":"Houston Press | The Leading Independent News Source in Houston, Texas","Description":"Original reporting and compelling writing on local news, restaurants, arts and culture have made the Houston Press a vital resource for readers who want to understand and engage with their community.","Keywords":"Houston news, Texas news, Houston events, Texas events, Houston Press","TwitterURL":"https:\/\/twitter.com\/houstonpress","FacebookURL":"https:\/\/www.facebook.com\/HoustonPress","InstagramURL":"http:\/\/instagram.com\/houstonpress","PinterestURL":"","LatitudeDefault":"29.81996","LongitudeDefault":"-95.35890","TwitterUser":"houstonpress"};
	});
</script>
	
                    <div class="top-sticky-ad">
        <div class="ads top" data-vmg-ad="Top" id="appnexus-ANLBTop" data-pos="above" data-vmg-format="normal"></div>    </div>


            </div><!-- /.container-fluid -->
        </div><!-- /.all-body -->
    </div><!-- /.wrapper -->
    <div class="compliance">
    <p>We use cookies to collect and analyze information on site performance and usage, and to enhance and customize content and advertisements. By clicking 'X' or continuing to use the site, you agree to allow cookies to be placed. To find out more, visit our <a href="/about/cookies">cookies policy</a> and our <a href="/about/privacy-policy">privacy policy</a>.</p>
    <button id="complianceAgree">&nbsp;</button>
</div>
    
            
                <script type="text/javascript" data-vmg-ad-script="">
                    if (VMG && VMG.Ads) {
                        VMG.Ads.init({"url":"oascentral.houstonpress.com","offset":"300","positions":["ArticleMiddleLeaderboard","vmgInterstitial","Middle","Frame","Top","Middle1","rotatingrectangle","bottomsticky","Bottom"],"site_page":"www.houstonpress.com/music","query":"XE&Category=Music&Subcategory=Articles&XE","debug":0,"sharethroughKeys":{"desktop-lg":"5d4074f6","desktop":"5d4074f6","tablet":"5d4074f6","mobile":"bc34edb8"},"sharethroughPlacement":null,"bids":{"rubicon":{"accountId":"8065","siteId":"211962","zoneId":"1041424"},"oath":{"desktopRectangle":"4961911","desktopLB":"4961909","mobileRectangle":"4961913","mobileLB":"4961914","network":"11570.1"},"pulsepoint":{"desktopRectangle":"697673","mobileRectangle":"697673","tabletRectangle":"697673","desktopLB":"698139","mobileLB":"698140","tabletLB":"698141","publisherId":"562058"},"synacormedia":{"tabletLB":"84067","tabletRectangle":"84063","mobileLB":"84066","mobileRectangle":"84063","desktopLB":"84062","desktopRectangle":"84063"}}});
                    }
                </script>
            
            <script type="text/javascript" src="/js_cache/content-view.js?buildId=1568922512"></script><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script><script type="text/javascript">

    if (!window.VMG) {
        window.VMG = {};
    }
    if (!window.VMG.params) {
        window.VMG.params = {};
    }
    window.VMG.params.social = {"title":"Peter Frampton Says Goodbye to Houston in Powerful and Joyous Farewell Tour","url":"http:\/\/www.houstonpress.com\/music\/last-night-peter-frampton-at-the-woodlands-pavilion-11358487","twitterUser":"hprocksoff","twitterHashtag":""};

    window.VMG.params.pubName = 'Houston Press';
    window.VMG.params.domainName = 'houstonpress.com';
</script>
<script type="text/javascript" src="/js_cache/ads.js?buildId=1568922512"></script>    <script type="text/javascript" src="https://assets.myvoicenation.com/load/js/2/omni.js"></script>
    <script type="text/javascript">
   if (typeof Popularity === 'undefined') {
       var Popularity = {};
   }
   Popularity.item = {"ObjId":"11358487","ObjectType":"Content","PubId":"hou","PublishDate":"2019-09-22","CategoryId":"6357953","CategoryName":"Rocks Off","SectionId":"6202219","SectionName":"Music","Topics":{"6362198":"Classic Rock Corner","6362276":"Concerts","7372477":"History","6362322":"Music","6362229":"Rock"},"Authors":{"6356364":"Bob Ruggiero"}};
</script>        <script type="text/javascript" src="/js_cache/omni-bindings.js?buildId=1568922512"></script>    <script type="text/javascript">
    var omniInitialConfig = {"cid":"hou","sid":"8|24|","localPath":"\/","authDomain":"www.myvoicenation.com","appId":"e52fed3340e68fcb0021fe2d0fd145a1"};
    if(window.MVN){
        MVN.onReady(function(){
                        omniInitialConfig.authDomain = "www.myvoicenation.com";
            MVN.init(omniInitialConfig);
        });
    }
</script>        
    <div id="fb-root"></div>
    <script>(function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=129990850394679&version=v2.3";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));
    </script>
    <script>
        !function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');
    </script>
    <script type="text/javascript">
$('document').ready(function() {
    if (typeof(Storage) !== "undefined") {
        // Only do ticketmaster national calls if sessionStorage is possible.
        window.VMG.nationalTM = {
            storageKey: 'vmg-hou-nat-tm',
            results: {},
            natTmClickrefs: [],
            natTmSections: [],
            render: function(tmKey, data) {
                if (data === null || data == '') {
                    return;
                }
                $('.nat-tm[data-clickref='+tmKey+']').parent().find('h2').html('Events Near You');
                $('.nat-tm[data-clickref='+tmKey+']').html(data);
            },
            getDistanceFromLatLonInMi: function (lat1,lon1,lat2,lon2) {
              var R = 3963; // Radius of the earth in miles
              var dLat = this.deg2rad(lat2-lat1);
              var dLon = this.deg2rad(lon2-lon1);
              var a =
                Math.sin(dLat/2) * Math.sin(dLat/2) +
                Math.cos(this.deg2rad(lat1)) * Math.cos(this.deg2rad(lat2)) *
                Math.sin(dLon/2) * Math.sin(dLon/2);
              var c = 2 * Math.atan2(Math.sqrt(a), Math.sqrt(1-a));
              var d = R * c; // Distance in km
              return d;
            },
            deg2rad: function (deg) {
              return deg * (Math.PI/180);
            }
        };
        window.VMG.nationalTM.results = JSON.parse(sessionStorage.getItem(window.VMG.nationalTM.storageKey));
        if ($('.nat-tm:visible').length == 0) {
            return;
        }
        if (!window.VMG.nationalTM.results) {
            window.VMG.nationalTM.results = {};
        }
        window.VMG.nationalTM.natTmClickrefs = $('.nat-tm:visible').map(function() { return $(this).data('clickref'); });
        window.VMG.nationalTM.natTmSections = $('.nat-tm:visible').map(function() { return $(this).data('section'); });
        // Make sure a ticket section actually exists on the page, add nat-tm class or something to them.

        if (window.VMG.Utils.checkGeoSupported()) {
            window.VMG.Utils.getGeoLocation(function(clientLat, clientLng) {
                var distance = window.VMG.nationalTM.getDistanceFromLatLonInMi(
                    clientLat, clientLng,
                    29.81996, -95.35890);
                if (distance > 100) {
                    for (var i=0; i < window.VMG.nationalTM.natTmClickrefs.length; i++) {
                        var tmKey = window.VMG.nationalTM.natTmClickrefs[i];
                        var tmSection = window.VMG.nationalTM.natTmSections[i];
                        if (typeof window.VMG.nationalTM.results[tmKey] == 'undefined') {
                            $.ajax(
                                "/national/ticketmaster",
                                {
                                    dataType: 'json',
                                    data: {
                                        section: tmSection,
                                        clickref: tmKey,
                                        page: i+1
                                    },
                                    success: function(data) {
                                        window.VMG.nationalTM.results[data.tmKey] = data.data;
                                        window.VMG.nationalTM.render(data.tmKey, window.VMG.nationalTM.results[data.tmKey]);
                                        sessionStorage.setItem(window.VMG.nationalTM.storageKey, JSON.stringify(window.VMG.nationalTM.results));

                                    }
                                }
                            );
                        } else {
                            window.VMG.nationalTM.render(tmKey, window.VMG.nationalTM.results[tmKey]);
                        }
                    }
                }
            },
            function() {
                // do nothing if we don't have geolocation stuff
            });
        }
    }
});
</script>
    <script src="https://apis.google.com/js/platform.js" async defer></script>
    <script type="text/javascript" src="https://www.google.com/recaptcha/api.js?onload=captchaCallback&render=explicit" async defer></script>
        <script type="text/javascript">
VMG.cityData = {"objid":"808579","creationdate":"2008-06-24 17:47:37","lastmodified":"2019-09-22 07:25:05","Name":"Houston Press","Publication":"hou","Domain":"houstonpress.com","PublicationCity":"Houston","Title":"Houston Press | The Leading Independent News Source in Houston, Texas","Description":"Original reporting and compelling writing on local news, restaurants, arts and culture have made the Houston Press a vital resource for readers who want to understand and engage with their community.","Keywords":"Houston news, Texas news, Houston events, Texas events, Houston Press","TwitterURL":"https:\/\/twitter.com\/houstonpress","FacebookURL":"https:\/\/www.facebook.com\/HoustonPress","InstagramURL":"http:\/\/instagram.com\/houstonpress","PinterestURL":"","LatitudeDefault":"29.81996","LongitudeDefault":"-95.35890","TwitterUser":"houstonpress"};
</script>

<div style="display: none">


<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '701597819931765'); // Insert your pixel ID here.
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=701597819931765&ev=PageView&noscript=1"/></noscript>






<script type='text/javascript'>
    var _sf_async_config = _sf_async_config || {};
    var _sf_async_config = {};
    _sf_async_config.uid = 10424;
    _sf_async_config.domain = 'houstonpress.com';
    _sf_async_config.useCanonical = true;
        _sf_async_config.sections = '/music';
        _sf_async_config.authors = 'Bob Ruggiero';
    (function() {
       function loadChartbeat() {
           window._sf_endpt = (new Date()).getTime();
           var e = document.createElement('script');
           e.setAttribute('language', 'javascript');
           e.setAttribute('type', 'text/javascript');
           e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
           document.body.appendChild(e);
       }
       var oldonload = document.ready;
       document.ready = (typeof document.ready != 'function') ? loadChartbeat : function() {
           oldonload();
           loadChartbeat();
       };
   })();
</script>
<!--  Quantcast Tag -->
<script>
 var ezt = ezt ||[];

 (function(){
   var elem = document.createElement('script');
   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://pixel") + ".quantserve.com/aquant.js?a=p-a4LDpi_DEopn-";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem,scpt);
 }());


 ezt.push({qacct: 'p-a4LDpi_DEopn-',
       uid: ''
           });
</script>
<noscript>
  <img src="//pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</noscript>
<!-- End Quantcast Tag -->


</div>
    



    


<div id="desktopSubModal" class="desktopSubModal">

    <div id="main-container" class="subscribe-modal-main">
        <div class="modalClose closeMod"></div>
        <img src="/theme/hou/img/logo-black.png" class="header" title="Get Connected!" alt=""/>        <h2>Newsletters</h2>
        <form id="subscribe">
            <div id="left">
                <p>All-access pass to the top stories, events and offers around town.</p>
                <ul class="subscriptions">
                    <li class="topStories">Top Stories
                        <div class="checkboxes">Send: 
                        </div>
                    </li>
                </ul>
            </div>
            <!-- right -->
            <div id="right">
                <input type="text" placeholder="email..." id="email" name="email">
                <div class="captcha">
                    <div id="subscribe-recaptcha" data-sitekey="6LcMCwgTAAAAAM86pPA6G1eIFDlL7iaeT3Y81A0Q"></div>
                </div>

                <div class="buttons">
                    <button type="button" id="sign-up">Sign Up <span>&gt;</span></button>
                    <button type="button" id="remind-me-later" class="remindLater">Remind Me Later <span>&gt;</span></button>
                    <button type="button" id="no-thanks" class="noThanks">No Thanks <span>&gt;</span></button>
                </div>
                <a href="/about/privacyPolicy/" class="privacyPolicy" target="_blank">Privacy Policy</a>
            </div>
        </form>
    </div>
</div>
<script type="text/javascript">
    window.VMG.hasDailyNL = 1;
    $('#desktopSubModal #email').on('focus', function(e){
        $('.subscribe-modal-main .captcha').show();
    })
    VMG.captchaQueue.queue(function(){
        grecaptcha.render('subscribe-recaptcha',{
            'sitekey' : $('#subscribe-recaptcha').data('sitekey')
        })
    })
</script>
    

    <div class="mobileSubModal">
        <div class="modalClose closeMod"></div>
        <h1 class="newsletters">Newsletters</h1>
        <p>All-access pass to top stories, events and offers around town.</p>
        <div class="sub_selections">
            <ul class="mob-sub-mod-subs">
            </ul>
        </div>
        <div id="desktop_modal">
            <div class="input-contain">
                <input type="text" name="subEmail" placeholder="email address" id="subEmail" />
            </div>
        </div>
        <h2>
            <a class="subFormLink" href="/profile/mobileSubscribe?url=http%3A%2F%2Fwww.houstonpress.com%2Fmusic%2Flast-night-peter-frampton-at-the-woodlands-pavilion-11358487">Sign Up &gt;</a>
        </h2>
        <h4 class="noThanks">No Thanks!</h4>
        <div class="subRemind">
            <h3 class="remindLater">Remind Me Later &gt;</h3>
        </div>
    </div>
    




</body>
</html>
