
<!DOCTYPE html>
<html class="uk-root" lang="en">
<head>
<link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=3470428e99c5591b0f614721b7fd5fc2" />
<script src="/fdn-system/assets/pub/scripts/uikit.js"></script>
<script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.js"></script>
<script src="/foundation/fontawesome/js/brands.min.js" async></script>
<script src="/foundation/fontawesome/js/solid.min.js" async></script>
<script src="/foundation/fontawesome/js/regular.min.js" async></script>
<script src="/foundation/fontawesome/js/fontawesome.min.js" async></script>
<script src="/foundation/fontawesome/js/light.min.js" async></script>
<script src="/foundation/fontawesome/js/duotone.min.js" async></script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta charset="UTF-8">
<meta name="layout" content="Content Default - Multiple (Responsive, Air)" />
<meta name="oid" content="12136457" />
<script>
window.__FOUNDATION_RESPONSIVE__ = true
// 
window.__FBAPIv__ = 'v3.2'
// 
</script>
<!--[if lte IE 8]>
<script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
<![endif]-->
<script>
if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
</script>
<script src="/foundation/scripts/common.js?cb=1b5bccfc8fdcc4aebe0058379f021c0c"></script>
<script src="/foundation/scripts/foundation-air.js?cb=1b5bccfc8fdcc4aebe0058379f021c0c"></script>
<link rel="alternate" type="application/rss+xml" title="Houston Press RSS: Whole Site" href="https://www.houstonpress.com/houston/Rss.xml" />
<link rel="alternate" type="application/rss+xml" title="Houston Press RSS: Music Section" href="https://www.houstonpress.com/houston/Rss.xml?oid=6202219" />
<link rel="alternate" type="application/rss+xml" title="Houston Press RSS: Rocks Off" href="https://www.houstonpress.com/houston/Rss.xml?oid=6357953" />
<script>
// rrr - What is this? 
fixupProfileLinks("https:\/\/www.houstonpress.com\/houston\/Profile", "https:\/\/posting.houstonpress.com\/houston\/MyProfile");
</script>
<meta name="google-signin-client_id" content="886013803489-3jo7v059jjmd44jilueuf7fi4vbshpan.apps.googleusercontent.com">

<link rel="preconnect" href="https://fonts.gstatic.com">
<link href="https://fonts.googleapis.com/css2?family=Oswald:wght@300;400;700&family=Roboto+Condensed:wght@300;400;700&family=Roboto+Slab:wght@400;700&family=Roboto:wght@100;300;400;500;700&display=swap" rel="stylesheet">
<style>
:root { 
--primary-color: #009;
--alt-primary-color: #900; 
}
</style>
<script>
!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>

<script>
var Pelcro = window.Pelcro || (window.Pelcro = {});
Pelcro.siteid = "1008";
Pelcro.environment = {
"ui": "https://js.pelcro.com/ui/plugin/west-word/main.min.js"
};
var Foundation = window.Foundation || (window.Foundation = {});
Foundation.Pelcro = window.Foundation.Pelcro || {};
Foundation.Pelcro.init = function () {
if (typeof(Foundation.Pelcro.user) === 'undefined' &&
typeof(Pelcro) === "object" &&
typeof(Pelcro.user) === "object" &&
Pelcro.user.isAuthenticated()) {
var user = Pelcro.user.read();
if (typeof(user) === "object" && !jQuery.isEmptyObject(user)) {
Foundation.Pelcro.user = user;
if (typeof(Foundation.Pelcro.user.subscriptions) === "object" &&
!jQuery.isEmptyObject(Foundation.Pelcro.user.subscriptions) &&
Foundation.Pelcro.user.subscriptions.length > 0) {
var subscription = Foundation.Pelcro.user.subscriptions[0];
if (subscription.status == "active") {
Foundation.Pelcro.subscription = subscription.plan.product.name;
}
}
jQuery(document).ready(function($) {
$(".pelcro-logout-button").click(function() {
Pelcro.user.logout();
});
$(".pelcro-logged-in").show();
$(".pelcro-logged-out").hide();
var email = Foundation.Pelcro.user.email;
if (email) {
var username = email;
if (username.length > 26) {
username = username.split("@", 1)[0];
}
$(".pelcro-user-name").html(username);
}
});
}
}
return (typeof(Foundation.Pelcro.user) === "object");
};
document.addEventListener("PelcroUserLogin", function (e) {
});
document.addEventListener("PelcroUserLogout", function (e) {
});
document.addEventListener("PelcroUserLoaded", function (e) {
Foundation.Pelcro.init();
});
</script>
<script async="" src="https://js.pelcro.com/sdk/main.min.js" type="text/javascript"></script>


<style>
.pelcro-logged-in {display:none;}
</style>

<style>
#pelcro-app .pelcro-prefix-view .pelcro-prefix-btn {
background: #900 !important;
border-color: #900 !important;
background-image: none !important;
}
#pelcro-app .pelcro-prefix-view .pelcro-prefix-btn:focus,
#pelcro-app .pelcro-prefix-view .pelcro-prefix-btn:hover
{
background: #900 !important;
border-color: #900 !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-link, #pelcro-app .pelcro-prefix-view a{
color: #900 !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-interval .active {
background-color: #900 !important;
color: white !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-plan-item.active {
background-color: #900 !important;
color: white !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-interval button {
color: #900 !important;
}
</style>
<script>
// 
var Foundation = window.Foundation || {};
Foundation.Pelcro = window.Foundation.Pelcro || {};
Foundation.Pelcro.pollCount = 0;
Foundation.Pelcro.pollForUser = setInterval(function() {
// 
if (Foundation.Pelcro.init() || Foundation.Pelcro.pollCount >= 100) {
// 
if (Foundation.Pelcro.init()) {
// 
var email = Foundation.Pelcro.user.email;
if (email) {
// 
jQuery(function() {
jQuery.get("https://posting.houstonpress.com/houston/API/Sailthru/User", {"email": email}).done(function(data) {
// 
var newsletters = data.newsletters;
if (Array.isArray(newsletters) &&
newsletters.length > 0) {
jQuery("div.MySubscriptions input[type='checkbox'][name='newsletter']").each(function (i, v) {
var e = jQuery(v);
var oid = e.data("fdnOid");
if (oid) {
e.prop("checked", (jQuery.inArray(oid, newsletters) !== -1)).change();
e.closest(".fdn-subscriptions-special-member-placement").toggleClass("fdn-subscriptions-special-member-placement", (jQuery.inArray(oid, newsletters) === -1));
}
});
}
// 
var token = data.token;
if (token) {
// 
jQuery('div.MySubscriptions input[type="checkbox"][name="newsletter"]').change(function () {
var oid = jQuery(this).data("fdnOid");
if (oid) {
var request = {
"token": token
};
request[this.checked?"subscribe":"unsubscribe"] = oid;
jQuery.post(
"https://posting.houstonpress.com/houston/API/Sailthru/User",
request
);
}
}).prop('disabled', false);
}
});
});
}
}
// 
else {
// 
}
clearInterval(Foundation.Pelcro.pollForUser);
if (Foundation.Pelcro.subscription == "Member" ||
Foundation.Pelcro.subscription == "Donor") {
jQuery("div.MySubscriptions .fdn-subscriptions-special-member-placement").removeClass("fdn-subscriptions-special-member-placement");
}
// 
if (Foundation.Pelcro.subscription == "Member") {
jQuery('[fdn-ad-component]').remove()
// One more time on document ready
jQuery(function() { jQuery('[fdn-ad-component]').remove() });
// 
}
// 
else {
if(window.Foundation && Foundation.ApnAds && typeof Foundation.ApnAds.setup === 'function') {
Foundation.ApnAds.setup();
}
// 
jQuery('wheresweed-nearby-businesses').closest('[hidden]').attr('hidden', false)
Foundation.WheresWeed = true
}
}
// 
else {
Foundation.Pelcro.pollCount++;
}
}, 30);
// 
jQuery(document).on("PelcroUserLogin", function (e) {
setTimeout(function() {
console.log(jQuery('body').removeClass('pelcro-modal-open').attr('class'))
}, 10);
});
// 
jQuery(function() {
jQuery('div.MySubscriptions input[type="checkbox"][name="newsletter"]').change(function () {
jQuery(this).siblings('.fdn-subscriptions-column-item-subscribed-header').text(this.checked?'Subscribed':'Unsubscribed');
}).change();
});
</script>
<meta name="ir-site-verification-token" value="-1062343762" />
<meta property="fb:pages" content="30682914119" />
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
<script type="text/javascript">
(function(document, window){
var script = document.createElement("script");
script.type = "text/javascript";
script.src = "https://api.pushnami.com/scripts/v1/pushnami-adv/610bf0d7d33ab0001172d8d4";
script.onload = function() {
Pushnami
.update({
"source":"pushnami"
})
.prompt();
};
document.getElementsByTagName("head")[0].appendChild(script);
})(document, window);
</script>
<link rel="manifest" href="https://www.houstonpress.com/manifest.json">

<script>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</script>
<script>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</script>
<script type="text/javascript">
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-395255-4', { 'siteSpeedSampleRate': 5 });
ga('set', 'dimension2', 'Music');
ga('set', 'dimension3', '12136457');
ga('set', 'dimension4', '2021-10-18 06:52:00');
ga('set', 'dimension5', 'Classic Rock Corner%Concerts');
ga('set', 'dimension6', 'Pete Vonder Haar');
ga('set', 'dimension7', 'Articles');
ga('send', 'pageview');
</script>

<script async src="https://cdn.avantisvideo.com/avm/js/video-loader.js?id=28be7cf9-a403-44c7-b272-eba9c55167ae&tagId=1" id='avantisJS'></script>
<script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
<script>
var Foundation = window.Foundation || (window.Foundation = {});
Foundation.SailthruSPM = window.Foundation.SailthruSPM || (window.Foundation.SailthruSPM = {});
Foundation.SailthruSPM.Personalize = function(options) {
const selector = options.selector;
const data = options.data;
const template = (typeof(options.template) === "function") ? options.template : (article) => `<li><a href="${article.url}" data-objid="${article.vars.objid}" title="${article.title}">${article.title}</a></li>`;
if (!selector) {
return;
}
else if (data.length == 0) {
return;
}
const elements = document.querySelectorAll(selector);
if (elements.length == 0) {
return;
}
const articles = JSON.parse(data.json);
const count = options.count ? options.count : articles.length;
const html = articles.slice(0, count).map(template);
elements.forEach(
element => {
if (!element.classList.contains("sailthruSPMLoaded")) {
element.innerHTML = html.join('');
element.classList.add("sailthruSPMLoaded");
}
}
);
}
Sailthru.init({
"isCustom": true,
"customerId": "e902d43c3b6fd1755d277bec05facac6"
});
</script>





<link rel="shortcut icon" href="/favicon.ico" />
<meta name="title" content="Review: James Taylor and Jackson Browne at the Toyota Center, 10/17/2021 | Houston Press" />
<meta name="description" content="James Taylor with an opener from Jackson Browne performed Sunday night in Houston." />
<meta name="keywords" content="James Taylor, Jackson Browne, Toyota Center" />
<title>Review: James Taylor and Jackson Browne at the Toyota Center, 10/17/2021 | Houston Press</title>
<meta name="date" content="2021-10-18 06:52:00" />
<meta name="author" content="Pete Vonder Haar">
<meta name="news_keywords" content="james taylor, jackson browne, toyota center" />
<link rel="image_src" href="https://media2.fdncms.com/hou/imager/u/slideshow/12139195/hou_rocks_20211018_jamestaylor_header.jpeg" />
<meta name="thumbnail" content="https://media2.fdncms.com/hou/imager/u/slideshow/12139195/hou_rocks_20211018_jamestaylor_header.jpeg" />
<link rel="canonical" href="https://www.houstonpress.com/music/review-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457" />
<meta property="og:url" content="https://www.houstonpress.com/music/review-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457" />
<meta property="fb:app_id" content="283068460220529" />
<meta property="og:site_name" content="Houston Press" />
<meta property="og:title" content="James Taylor And Jackson Browne Declare How Sweet It Is To Be Back In Houston" />
<meta property="og:image" content="https://media2.fdncms.com/hou/imager/u/slideshow/12139195/hou_rocks_20211018_jamestaylor_header.jpeg" />
<meta property="og:image:width" content="1524" />
<meta property="og:image:height" content="951" />
<meta property="og:description" content="James Taylor, Jackson Browne Toyota Center October 17, 2021 For GenX-ers like myself, now is truly the twilight of the artists who were more or less ubiquitous when we were growing up. It isn&#39;t just that half the Beatles are long dead, or that our only recollections of Hendrix, Joplin,..." />
<meta property="og:type" content="article" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://media2.fdncms.com/hou/imager/u/slideshow/12139195/hou_rocks_20211018_jamestaylor_header.jpeg">
<meta name="twitter:creator" content="@PeterVonderHaar">
<meta name="twitter:site" content="@houstonpress">
<meta name="twitter:title" content="James Taylor And Jackson Browne Declare How Sweet It Is To Be Back In Houston">
<meta name="twitter:description" content="James Taylor, Jackson Browne Toyota Center October 17, 2021 For GenX-ers like myself, now is truly the twilight of the artists who were more or less ubiquitous when we were growing up. It isn&#39;t just that half the Beatles are long dead, or that our only recollections of Hendrix, Joplin,...">

<script type="application/ld+json">
{
"mainEntityOfPage": {
"@type": "WebPage",
"@id":"https:\/\/www.houstonpress.com\/music\/review-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457"
},
"headline": "James Taylor And Jackson Browne Declare How Sweet It Is To Be Back In Houston",
"description": "James Taylor, Jackson Browne Toyota Center October 17, 2021 For GenX-ers like myself, now is truly the twilight of the artists who were more or less ubiquitous when we were growing up. It isn't just that half the Beatles are long dead, or that our only recollections of Hendrix, Joplin,...",
"image": {
"url": "https:\/\/media2.fdncms.com\/hou\/imager\/u\/original\/12139195\/hou_rocks_20211018_jamestaylor_header.jpeg",
"width": 800,
"height": 499,
"@type": "ImageObject"
},
"datePublished": "2021-10-18T06:52:00",
"dateModified": "2021-10-18T07:10:38",
"author": {
"name": "Pete Vonder Haar",
"@type": "Person"
},
"publisher": {
"name": "Houston Press",
"logo": {
"url": "https:\/\/www.houstonpress.com\/imager\/b\/google-amp-logo\/808579\/1aca\/Houston_Press-icon_logo.png",
"width": 1922,
"height": 2356,
"@type": "ImageObject"
},
"@type": "Organization"
},
"@context": "https://schema.org",
"@type": "NewsArticle"
}
</script>
<script>window.twttr = (function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0],
t = window.twttr || {};
if (d.getElementById(id)) return t;
js = d.createElement(s);
js.id = id;
js.src = "https://platform.twitter.com/widgets.js";
fjs.parentNode.insertBefore(js, fjs);
t._e = [];
t.ready = function(f) {
t._e.push(f);
};
return t;
}(document, "script", "twitter-wjs"));</script>
</head>
<script src="/fdn-system/assets/pub/scripts/ResizeSensor.js"></script>
<script src="/fdn-system/assets/pub/scripts/ElementQueries.js"></script>
<script>
ElementQueries.listen();
</script>
<body id="Content" class="ContentDefault music RespOneCol rocks">
<script>
ElementQueries.init();
</script>
<div id="fdn-navigation-dropdown-hook" style="width:100%;height:0;position:fixed;"></div>
<div id="fb-root"></div>
<script>
(function () {
var app = new Foundation.Facebook.Application();
app.receiveAuthNotifications();
app.receiveLikeNotifications();
})();
</script>
<script>
(function () {
var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
//if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
}.bind(this), function(){
if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
})
})()
</script>
<div id="ContentDefault" class="grid-resp-1 page layout-ContentDefault">
<div class="ev-grid-layout ev-clamp@m ev-clamp@l">
<div class="ev-grid-zone ev-leader-zone">
<div class="ev-grid-col uk-width-1-1" data-ev-zone="Leader">
</div>
</div>
<div class="ev-grid-zone ev-header-zone">
<div class="ev-grid-col uk-width-1-1" data-ev-zone="GlobalHeader">
<div uk-sticky class="GlobalHeader ContentDefaultMultiple   uk-root fdn-margin-vert SiteHeaderGrid comp-shell-siteheader" data-component-id="SiteHeaderGrid">
<div class="fdn-site-header-flex">
<div class="fdn-site-header-nav-toggle-narrow uk-hidden@sm">
<a href="#offcanvas-slide-navigation" class="fdn-nav-toggle uk-button" uk-toggle>
<i class="fal fa-bars fa-2x"></i>
</a>
<div id="offcanvas-slide-navigation" uk-offcanvas="overlay: true">
<div id="site-nav-target" class="fdn-nav-panel-block uk-offcanvas-bar">
<ul class="site-nav-source uk-width-1-1 uk-nav uk-nav-parent-icon" uk-nav="multiple: false;">
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestNews">
<a href="https://www.houstonpress.com/news" onclick="ga(" send", "event", "Nav", "Click", "Latest News")" target="_self">News<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/news" onclick="ga(" send", "event", "Nav", "Click", "Latest News")" target="_self" title="">Latest News</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/sports-6362239" onclick="ga(" send", "event", "Nav", "Click", "Sports")" target="_self" title="">Sports</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/longform-6357753" onclick="ga(" send", "event", "Nav", "Click", "Longform")" target="_self" title="">Longform</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582337" onclick="ga(" send", "event", "Nav", "Click", "Daily Newsletter")" target="_self" title="">Daily Newsletter</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582348" onclick="ga(" send", "event", "Nav", "Click", "Weekly Newsletter")" target="_self" title="">Weekly Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestFoodDrink">
<a href="https://www.houstonpress.com/restaurants" onclick="ga(" send", "event", "Nav", "Click", "Latest Food & Drink")" target="_self">Food &amp; Drink<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/restaurants" onclick="ga(" send", "event", "Nav", "Click", "Latest Food & Drink")" target="_self" title="">Latest Food &amp; Drink</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/restaurant-reviews-6362359" onclick="ga(" send", "event", "Nav", "Click", "Restaurant Reviews")" target="_self" title="">Restaurant Reviews</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582338" onclick="ga(" send", "event", "Nav", "Click", "Food & Drink Newsletter")" target="_self" title="">Food &amp; Drink Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestArtsCulture">
<a href="https://www.houstonpress.com/arts" onclick="ga(" send", "event", "Nav", "Click", "Latest Arts & Culture")" target="_self">Arts &amp; Culture<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/arts" onclick="ga(" send", "event", "Nav", "Click", "Latest Arts & Culture")" target="_self" title="">Latest Arts &amp; Culture</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/100-creatives-6362314" onclick="ga(" send", "event", "Nav", "Click", "100 Houston Creatives")" target="_self" title="">100 Houston Creatives</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/stage-6362234" onclick="ga(" send", "event", "Nav", "Click", "Stage")" target="_self" title="">Stage</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/EventSearch?narrowByDate=today&sortType=date&v=g" onclick="ga(" send", "event", "Nav", "Click", "Calendar")" target="_self" title="">Calendar</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/Events/AddEvent?eventSection=6377141" onclick="ga(" send", "event", "Nav", "Click", "Submit an Event")" target="_self" title="">Submit an Event</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/MovieTimes" onclick="ga(" send", "event", "Nav", "Click", "Movie Times")" target="_self" title="">Movie Times</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpressartsguide.com/" onclick="ga(" send", "event", "Nav", "Click", "HoustonPressArtsGuide.com")" target="_self" title="">HoustonPressArtsGuide.com</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582346" onclick="ga(" send", "event", "Nav", "Click", "Arts & Culture Newsletter")" target="_self" title="">Arts &amp; Culture Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestMusic">
<a href="https://www.houstonpress.com/music" onclick="ga(" send", "event", "Nav", "Click", "Latest Music")" target="_self">Music<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/music" onclick="ga(" send", "event", "Nav", "Click", "Latest Music")" target="_self" title="">Latest Music</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/concerts-6362276" onclick="ga(" send", "event", "Nav", "Click", "Concerts")" target="_self" title="">Concerts</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/EventSearch?eventSection=6805301&feature=Concert&sortType=date&v=g" onclick="ga(" send", "event", "Nav", "Click", "Concert Calendar")" target="_self" title="">Concert Calendar</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/Events/AddEvent?eventSection=6805301" onclick="ga(" send", "event", "Nav", "Click", "Submit a Music Event")" target="_self" title="">Submit a Music Event</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582344" onclick="ga(" send", "event", "Nav", "Click", "Music Newsletter")" target="_self" title="">Music Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-ThingstoDo">
<a href="https://www.houstonpress.com/about" onclick="ga(" send", "event", "Nav", "Click", "Things to Do\ Tickets")" target="_self">More<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/things-to-do" onclick="ga(" send", "event", "Nav", "Click", "Things to Do\ Tickets")" target="_self" title="">Things to Do/Tickets</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/best-of-houston-2021-11828047" onclick="ga(" send", "event", "Nav", "Click", "Best of Houston")" target="_self" title="">Best of Houston</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/microsites/best-of-houston-2021-readers-choice-winners/" onclick="ga(" send", "event", "Nav", "Click", "Best of Houston Readers' Choice Winners")" target="_self" title="">Best of Houston Readers&#39; Choice Winners</a>
</li>
<li class="fdn-nav-item">
<a href="https://herbanplanet.com/" onclick="ga(" send", "event", "Nav", "Click", "Cannabis")" target="_blank" title="">Cannabis</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/SlideshowArchives" onclick="ga(" send", "event", "Nav", "Click", "Slideshows")" target="_self" title="">Slideshows</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/promotions" onclick="ga(" send", "event", "Nav", "Click", "Promotions")" target="_self" title="">Promotions</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/lists-6362201" onclick="ga(" send", "event", "Nav", "Click", "Lists")" target="_self" title="">Lists</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/about/careers" onclick="ga(" send", "event", "Nav", "Click", "Houston Press Careers")" target="_self" title="">Houston Press Careers</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/advertise" onclick="ga(" send", "event", "Nav", "Click", "Local Advertising")" target="_self" title="">Local Advertising</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/about/flipbooks" onclick="ga(" send", "event", "Nav", "Click", "Flipbook Archive")" target="_self" title="">Flipbook Archive</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582339" onclick="ga(" send", "event", "Nav", "Click", "Things To Do Newsletter")" target="_self" title="">Things To Do Newsletter</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582335" onclick="ga(" send", "event", "Nav", "Click", "Best Of Newsletter")" target="_self" title="">Best Of Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-DallasObserver">
<a href="https://www.voicemediagroup.com/" onclick="ga(" send", "event", "Nav", "Click", "Dallas Observer")" target="_self">Voice Media Group<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.dallasobserver.com/" onclick="ga(" send", "event", "Nav", "Click", "Dallas Observer")" target="_blank" title="">Dallas Observer</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.phoenixnewtimes.com/" onclick="ga(" send", "event", "Nav", "Click", "Phoenix New Times")" target="_blank" title="">Phoenix New Times</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/" onclick="ga(" send", "event", "Nav", "Click", "New Times Broward-Palm Beach")" target="_blank" title="">New Times Broward-Palm Beach</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/" onclick="ga(" send", "event", "Nav", "Click", "Miami New Times")" target="_blank" title="">Miami New Times</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.westword.com/" onclick="ga(" send", "event", "Nav", "Click", "Westword")" target="_blank" title="">Westword</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.couponscaptain.com/" onclick="ga(" send", "event", "Nav", "Click", "Coupons Captain")" target="_blank" title="">Coupons Captain</a>
</li>
</ul>
</li>
</ul>
<div class="fdn-site-header-search-block">
<form action="https://www.houstonpress.com/houston/Search" method="get">
<div class="fdn-site-header-search-wrap">
<input type="text" name="keywords" autocomplete="off" type="search" class="fdn-site-header-search-input" placeholder="Search">
<button class="fdn-site-header-search-submit" type="submit"><i class="far fa-search fa-flip-horizontal"></i></button>
</div>
</form>
</div>
</div>
</div>
</div>
<div class="fdn-site-header-nav-toggle-wide uk-visible@sm">
<a class="fdn-nav-toggle uk-button">
<i class="fal fa-bars fa-2x"></i>
</a>
<div id="fdn-site-header-nav-toggle-wide-modal" class="fdn-site-header-nav-wide" uk-drop="mode: click; boundary: #fdn-navigation-dropdown-hook; boundary-align: true; pos: bottom-justify; offset: 100;">
<div class="uk-width-1-1 fdn-site-header-nav-wide-columns uk-modal-dialog">
<div class=" uk-flex uk-flex-wrap fdn-site-header-nav-wide-column-wrap">
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.houstonpress.com/news" onclick="ga(" send", "event", "Nav", "Click", "News")" target="_self" title="">
News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/news" onclick="ga(" send", "event", "Nav", "Click", "Latest News")" target="_self" title="">
Latest News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/sports-6362239" onclick="ga(" send", "event", "Nav", "Click", "Sports")" target="_self" title="">
Sports
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/longform-6357753" onclick="ga(" send", "event", "Nav", "Click", "Longform")" target="_self" title="">
Longform
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582337" onclick="ga(" send", "event", "Nav", "Click", "Daily Newsletter")" target="_self" title="">
Daily Newsletter
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582348" onclick="ga(" send", "event", "Nav", "Click", "Weekly Newsletter")" target="_self" title="">
Weekly Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.houstonpress.com/restaurants" onclick="ga(" send", "event", "Nav", "Click", "Food & Drink")" target="_self" title="">
Food &amp; Drink
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/restaurants" onclick="ga(" send", "event", "Nav", "Click", "Latest Food & Drink")" target="_self" title="">
Latest Food &amp; Drink
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/restaurant-reviews-6362359" onclick="ga(" send", "event", "Nav", "Click", "Restaurant Reviews")" target="_self" title="">
Restaurant Reviews
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582338" onclick="ga(" send", "event", "Nav", "Click", "Food & Drink Newsletter")" target="_self" title="">
Food &amp; Drink Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.houstonpress.com/arts" onclick="ga(" send", "event", "Nav", "Click", "Arts & Culture")" target="_self" title="">
Arts &amp; Culture
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/arts" onclick="ga(" send", "event", "Nav", "Click", "Latest Arts & Culture")" target="_self" title="">
Latest Arts &amp; Culture
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/100-creatives-6362314" onclick="ga(" send", "event", "Nav", "Click", "100 Houston Creatives")" target="_self" title="">
100 Houston Creatives
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/stage-6362234" onclick="ga(" send", "event", "Nav", "Click", "Stage")" target="_self" title="">
Stage
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/EventSearch?narrowByDate=today&sortType=date&v=g" onclick="ga(" send", "event", "Nav", "Click", "Calendar")" target="_self" title="">
Calendar
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/Events/AddEvent?eventSection=6377141" onclick="ga(" send", "event", "Nav", "Click", "Submit an Event")" target="_self" title="">
Submit an Event
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/MovieTimes" onclick="ga(" send", "event", "Nav", "Click", "Movie Times")" target="_self" title="">
Movie Times
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpressartsguide.com/" onclick="ga(" send", "event", "Nav", "Click", "HoustonPressArtsGuide.com")" target="_self" title="">
HoustonPressArtsGuide.com
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582346" onclick="ga(" send", "event", "Nav", "Click", "Arts & Culture Newsletter")" target="_self" title="">
Arts &amp; Culture Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.houstonpress.com/music" onclick="ga(" send", "event", "Nav", "Click", "Music")" target="_self" title="">
Music
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/music" onclick="ga(" send", "event", "Nav", "Click", "Latest Music")" target="_self" title="">
Latest Music
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/concerts-6362276" onclick="ga(" send", "event", "Nav", "Click", "Concerts")" target="_self" title="">
Concerts
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/EventSearch?eventSection=6805301&feature=Concert&sortType=date&v=g" onclick="ga(" send", "event", "Nav", "Click", "Concert Calendar")" target="_self" title="">
Concert Calendar
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/Events/AddEvent?eventSection=6805301" onclick="ga(" send", "event", "Nav", "Click", "Submit a Music Event")" target="_self" title="">
Submit a Music Event
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582344" onclick="ga(" send", "event", "Nav", "Click", "Music Newsletter")" target="_self" title="">
Music Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.houstonpress.com/about" onclick="ga(" send", "event", "Nav", "Click", "More")" target="_self" title="">
More
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/things-to-do" onclick="ga(" send", "event", "Nav", "Click", "Things to Do\ Tickets")" target="_self" title="">
Things to Do/Tickets
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/best-of-houston-2021-11828047" onclick="ga(" send", "event", "Nav", "Click", "Best of Houston")" target="_self" title="">
Best of Houston
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/microsites/best-of-houston-2021-readers-choice-winners/" onclick="ga(" send", "event", "Nav", "Click", "Best of Houston Readers' Choice Winners")" target="_self" title="">
Best of Houston Readers&#39; Choice Winners
</a>
</li>
<li class="fdn-nav-item">
<a href="https://herbanplanet.com/" onclick="ga(" send", "event", "Nav", "Click", "Cannabis")" target="_blank" title="">
Cannabis
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/houston/SlideshowArchives" onclick="ga(" send", "event", "Nav", "Click", "Slideshows")" target="_self" title="">
Slideshows
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/promotions" onclick="ga(" send", "event", "Nav", "Click", "Promotions")" target="_self" title="">
Promotions
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/topic/lists-6362201" onclick="ga(" send", "event", "Nav", "Click", "Lists")" target="_self" title="">
Lists
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/about/careers" onclick="ga(" send", "event", "Nav", "Click", "Houston Press Careers")" target="_self" title="">
Houston Press Careers
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/advertise" onclick="ga(" send", "event", "Nav", "Click", "Local Advertising")" target="_self" title="">
Local Advertising
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/about/flipbooks" onclick="ga(" send", "event", "Nav", "Click", "Flipbook Archive")" target="_self" title="">
Flipbook Archive
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582339" onclick="ga(" send", "event", "Nav", "Click", "Things To Do Newsletter")" target="_self" title="">
Things To Do Newsletter
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/profile?newsletter=11582335" onclick="ga(" send", "event", "Nav", "Click", "Best Of Newsletter")" target="_self" title="">
Best Of Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.voicemediagroup.com/" onclick="ga(" send", "event", "Nav", "Click", "Voice Media Group")" target="_self" title="">
Voice Media Group
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.dallasobserver.com/" onclick="ga(" send", "event", "Nav", "Click", "Dallas Observer")" target="_blank" title="">
Dallas Observer
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.phoenixnewtimes.com/" onclick="ga(" send", "event", "Nav", "Click", "Phoenix New Times")" target="_blank" title="">
Phoenix New Times
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/" onclick="ga(" send", "event", "Nav", "Click", "New Times Broward-Palm Beach")" target="_blank" title="">
New Times Broward-Palm Beach
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/" onclick="ga(" send", "event", "Nav", "Click", "Miami New Times")" target="_blank" title="">
Miami New Times
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.westword.com/" onclick="ga(" send", "event", "Nav", "Click", "Westword")" target="_blank" title="">
Westword
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.couponscaptain.com/" onclick="ga(" send", "event", "Nav", "Click", "Coupons Captain")" target="_blank" title="">
Coupons Captain
</a>
</li>
</ul>
</div>
</div>
<div class="fdn-site-header-search-block">
<form action="https://www.houstonpress.com/houston/Search" method="get">
<div class="fdn-site-header-search-wrap">
<input type="text" name="keywords" autocomplete="off" type="search" class="fdn-site-header-search-input" placeholder="Search houstonpress.com">
<button class="fdn-site-header-search-submit" type="submit">
<i class="far fa-search fa-flip-horizontal"></i>
</button>
</div>
</form>
</div>
</div>
</div>
<div class="fdn-site-header-logo">
<div class="GlobalHeader SiteLogoresponsive  uk-root SiteLogo comp-shell-logo" data-component-id="SiteLogo">
<div class="uk-margin-remove">
<a class="uk-logo" href="https://www.houstonpress.com/" title="Houston Press">
<img src="/images/hou-main-logo.png" alt="Houston Press">
</a>
</div>
</div>
</div>
<div class="fdn-site-header-text-block">
<div class="uk-flex uk-flex-wrap uk-flex-middle">
<a class="uk-width-auto fdn-site-header-support-button" href="https://www.houstonpress.com/i-support" onclick="ga('send', 'event', 'VMG-Widget', 'Click', 'Music-VMG-ISupport-Header',  {'NonInteraction': 1});">
Support Us
</a>
<p class="uk-width-2-3@sm uk-width-1-2 fdn-site-header-slogan uk-margin-remove">
Houston's independent source of<br>
local news and culture
</p>
</div>
</div>
<div class="uk-flex uk-flex-middle fdn-site-header-login-block">
<p class="uk-margin-remove uk-button">
<i class="fas fa-2x fa-user"></i>
<span class="uk-visible@sm">account</span>
<i class="fas fa-chevron-right"></i>
</p>
<div class="uk-padding-small" uk-dropdown="mode:click">
<ul class="uk-nav uk-nav-default uk-dropdown-nav">
<li class="pelcro-logged-in uk-nav-header">Welcome,<br /><span class="pelcro-user-name">Insider</span></li>
<li class="pelcro-logged-out"><a href="#" class="pelcro-login-button" data-vmgs-psource="Toolbar|Music" data-vmgs-section="Music">Login</a></li>
<li class="pelcro-logged-in"><a href="/profile">My Newsletters</a></li>
<li class=""><a href="/contribute">Contribute</a></li>
<li class=""><a href="/about/contact">Contact Us</a></li>
<li class="pelcro-logged-in pelcro-logout-button"><a href="">Sign out</a></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="ev-grid-zone ev-primary-zone">
<div class="ev-grid-col fdn-grid-main-single fdn-primary" data-ev-zone="MainTop">
<div class="ZoneA ContentDefaultMultiple  uk-inline uk-margin-remove-top uk-root fdn-margin-vert ContentRowMultiple comp-content-contentmultirow" data-component-id="ContentRowMultiple">
<div class="content-multiple-item" fdn-content-multi-item="12136457" fdn-content-multi-item-headline="James Taylor And Jackson Browne Declare How Sweet It Is To Be Back In Houston" fdn-content-multi-item-permalink="/music/review-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457" fdn-content-multi-item-canonical="https://www.houstonpress.com/music/review-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457" fdn-content-multi-item-title="James Taylor And Jackson Browne Declare How Sweet It Is To Be Back In Houston" fdn-content-multi-item-thumb="https://media2.fdncms.com/hou/imager/u/slideshow/12139195/hou_rocks_20211018_jamestaylor_header.jpeg?cb=1634559015" fdn-content-multi-item-thumb-width="1524" fdn-content-multi-item-thumb-height="951" ga-dimension2="Music" ga-dimension3="12136457" ga-dimension4="2021-10-18 06:52:00" ga-dimension5="Classic Rock Corner%Concerts" ga-dimension6="Pete Vonder Haar" ga-dimension7="Articles">
<div class="ZoneA StoryHeaderCustomresponsive   uk-root fdn-margin-vert StoryHeaderCustom comp-content-storyheader" data-component-id="StoryHeaderCustom">
<div class="fdn-custom-story-header">
<p class="fdn-custom-story-header-topic uk-margin-remove-top uk-margin-small-bottom">
<a href="https://www.houstonpress.com/topic/classic-rock-corner-6362198">
Classic Rock Corner
</a>
</p>
<div class="uk-position-relative uk-visible-toggle">
<div class="uk-hidden-hover uk-position-top-right uk-padding-xsmall uk-position-absolute">
</div>
<h1 class="fdn-content-headline uk-margin-remove">
James Taylor And Jackson Browne Declare How Sweet It Is To Be Back In Houston
</h1>
<p class="fdn-content-infoline">
<span class="fdn-custom-story-header-author">
<a href="https://www.houstonpress.com/author/pete-vonder-haar" rel="author">
Pete Vonder Haar
</a>
</span>
<span class="fdn-custom-story-header-date">
October 18, 2021
</span>
<span class="fdn-custom-story-header-time">
6:52AM
</span>
</p>
</div>
</div>
</div>
<div class="uk-width-1-1 uk-flex uk-flex-row">
<div class="uk-width-expand uk-flex uk-flex-column" main-column>
<div class="uk-width-1-1">
<div class="uk-margin-remove-top fdn-magnum-block uk-clearfix magnumTest">
<img uk-img="" data-src="https://media2.fdncms.com/hou/imager/u/magnum/12139195/hou_rocks_20211018_jamestaylor_header.jpeg?cb=1634559015" alt="James Taylor sported the latest Boston grandfather style." width="1320" height="823" class="" />
<div class="fdn-caption-block uk-flex uk-flex-middle uk-flex-row">
<span class="fdn-image-caption">James Taylor sported the latest Boston grandfather style.</span>
<span class="fdn-image-credit">Photo by Jack Gorman</span>
</div>
</div>
</div>
<div class="uk-width-1-1 uk-flex uk-flex-row uk-flex-middle uk-flex-left uk-grid-small fdn-content-multi-row-share-tools-small " uk-grid>
<div fdn-share-button-facebook="">
<a href="https://www.facebook.com/sharer/sharer.php?u=https:%2F%2Fwww.houstonpress.com%2Fmusic%2Freview-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457&redirect_uri=https:%2F%2Fwww.houstonpress.com%2Fmusic%2Freview-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457&app_id=283068460220529" onClick="window.open('https://www.facebook.com/sharer/sharer.php?u=https:%2F%2Fwww.houstonpress.com%2Fmusic%2Freview-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457&redirect_uri=https:%2F%2Fwww.houstonpress.com%2Fmusic%2Freview-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457&app_id=283068460220529','_blank','resizable,height=700,width=600'); return false;" target="_blank" uk-tooltip="title: Share on Facebook" aria-expanded="false">
<span class="uk-icon-button fdn-icon-button-smaller uk-icon" uk-icon="icon:facebook; ratio: .77"><svg width="15.4" height="15.4" viewBox="0 0 20 20" xmlns="http://www.w3.org/2000/svg" data-svg="facebook"><path d="M11,10h2.6l0.4-3H11V5.3c0-0.9,0.2-1.5,1.5-1.5H14V1.1c-0.3,0-1-0.1-2.1-0.1C9.6,1,8,2.4,8,5v2H5.5v3H8v8h3V10z"></path></svg></span>
</a>
</div>
<script> dnLoadScript("https://platform.twitter.com/widgets.js", true); </script>
<div class="" fdn-share-button-twitter="">
<a href="https://twitter.com/intent/tweet?url=https:%2F%2Fwww.houstonpress.com%2Fmusic%2Freview-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457&redirect_uri=https:%2F%2Fwww.houstonpress.com%2Fmusic%2Freview-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457&text=James%20Taylor%20And%20Jackson%20Browne%20Declare%20How%20Sweet%20It%20Is%20To%20Be%20Back%20In%20Houston" onClick="window.open('https://twitter.com/intent/tweet?url=https:%2F%2Fwww.houstonpress.com%2Fmusic%2Freview-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457&redirect_uri=https:%2F%2Fwww.houstonpress.com%2Fmusic%2Freview-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457&text=James%20Taylor%20And%20Jackson%20Browne%20Declare%20How%20Sweet%20It%20Is%20To%20Be%20Back%20In%20Houston','_blank','resizable,height=700,width=600'); return false;" uk-tooltip="title: Share on Twitter" aria-expanded="false">
<span class="uk-icon-button fdn-icon-button-smaller uk-icon" uk-icon="icon:twitter; ratio: .77"><svg width="15.4" height="15.4" viewBox="0 0 20 20" xmlns="http://www.w3.org/2000/svg" data-svg="twitter"><path d="M19,4.74 C18.339,5.029 17.626,5.229 16.881,5.32 C17.644,4.86 18.227,4.139 18.503,3.28 C17.79,3.7 17.001,4.009 16.159,4.17 C15.485,3.45 14.526,3 13.464,3 C11.423,3 9.771,4.66 9.771,6.7 C9.771,6.99 9.804,7.269 9.868,7.539 C6.795,7.38 4.076,5.919 2.254,3.679 C1.936,4.219 1.754,4.86 1.754,5.539 C1.754,6.82 2.405,7.95 3.397,8.61 C2.79,8.589 2.22,8.429 1.723,8.149 L1.723,8.189 C1.723,9.978 2.997,11.478 4.686,11.82 C4.376,11.899 4.049,11.939 3.713,11.939 C3.475,11.939 3.245,11.919 3.018,11.88 C3.49,13.349 4.852,14.419 6.469,14.449 C5.205,15.429 3.612,16.019 1.882,16.019 C1.583,16.019 1.29,16.009 1,15.969 C2.635,17.019 4.576,17.629 6.662,17.629 C13.454,17.629 17.17,12 17.17,7.129 C17.17,6.969 17.166,6.809 17.157,6.649 C17.879,6.129 18.504,5.478 19,4.74"></path></svg></span>
</a>
</div>
<div class="" fdn-share-button-email="">
<a href="/cdn-cgi/l/email-protection#ab94d8dec9c1cec8df96e3c4ded8dfc4c58e999bfbd9ced8d88e98ea8e999be1cac6ced88e999bffcad2c7c4d98e999beac5cf8e999be1cac8c0d8c4c58e999be9d9c4dcc5ce8e999befcec8c7cad9ce8e999be3c4dc8e999bf8dccecedf8e999be2df8e999be2d88e999bffc48e999be9ce8e999be9cac8c08e999be2c58e999be3c4ded8dfc4c58dc9c4cfd2968e9bea8e9beae1cac6ced88e999bffcad2c7c4d98e999beac5cf8e999be1cac8c0d8c4c58e999be9d9c4dcc5ce8e999befcec8c7cad9ce8e999be3c4dc8e999bf8dccecedf8e999be2df8e999be2d88e999bffc48e999be9ce8e999be9cac8c08e999be2c58e999be3c4ded8dfc4c58e9bea8e9beac3dfdfdbd8918484dcdcdc85c3c4ded8dfc4c5dbd9ced8d885c8c4c684c6ded8c2c884d9ceddc2cedc86c1cac6ced886dfcad2c7c4d986cac5cf86c1cac8c0d8c4c586c9d9c4dcc5ce86cadf86dfc3ce86dfc4d2c4dfca86c8cec5dfced9869a9b869a9c86999b999a869a999a989d9f9e9c8e9bea8e9bea8e9bea" onclick="mailto:?subject=Houston%20Press%3A%20James%20Taylor%20And%20Jackson%20Browne%20Declare%20How%20Sweet%20It%20Is%20To%20Be%20Back%20In%20Houston&body=%0A%0AJames%20Taylor%20And%20Jackson%20Browne%20Declare%20How%20Sweet%20It%20Is%20To%20Be%20Back%20In%20Houston%0A%0Ahttps://www.houstonpress.com/music/review-james-taylor-and-jackson-browne-at-the-toyota-center-10-17-2021-12136457%0A%0A%0A" uk-tooltip="title: Share via Email" aria-expanded="false" rel="nofollow">
<i class="fal fa-envelope fa-lg"></i>
</a>
</div>
<div class="" fdn-share-button-print>
<a href="https://www.houstonpress.com/houston/Print?oid=12136457" target="_blank" uk-tooltip="title:Print" title="" aria-expanded="false">
<i class="fal fa-print fa-lg"></i>
</a>
</div>
<div class="" fdn-share-button-text-size>
<a class="fdn-text-size-toggle" href="#size" uk-tooltip="title:Change Font Size" aria-expanded="false" uk-toggle="target: .fdn-content-body;cls: fdn-content-body-large;">
<i class="fas fa-text-size fa-lg"></i>
</a>
</div>
</div>
<div class="uk-width-1-1 uk-flex uk-flex-row">
<div class="uk-width-expand fdn-content-multi-row show-first-image">
<div class="ZoneA StoryLayoutresponsive   uk-root fdn-margin-vert StoryLayout comp-content-storylayout" data-component-id="StoryLayout">
<div class="fdn-content-body">
<b>James Taylor, Jackson Browne<br>
Toyota Center<br>
October 17, 2021
<br>
<br>
</b>For GenX-ers like myself, now is truly the twilight of the artists who were more or less ubiquitous when we were growing up. It isn't just that half the Beatles are long dead, or that our only recollections of Hendrix, Joplin, and Morrison are via ancient footage, but also how many of our favorite acts of yore are packing it in once and for all.
<br>
<br>
It's a topic I touched upon in <a href="/music/review-paul-simon-at-the-toyota-center-060218-10537146" target="_blank">my review</a> of Paul Simon's farewell show, but the phenomenon has snowballed in recent years. Understandably so, given the aging of these Boomer stalwarts. In addition to Simon, recent years have seen/will see the retirements of Joan Baez, Bob Seger, Genesis, Lynyrd Skynyrd Elton John, and KISS(?)
<br>
<br>
But don't put James Taylor or Jackson Browne in that category. The two, both in their 70s, have released albums recently (Browne's <i>Downhill from Everywhere</i>&nbsp;came out this year, Taylor <i>American Standard</i>&nbsp;in 2020) and show no signs of calling it quits. That point was made — if not emphatically so — last night at the Toyota Center, where each singer-songwriter leaned heavily on the nostalgia factor in front of a [ - ] Sunday night crowd.
<div class="uk-padding-remove fdn-override-width-1-1">
<div class="ZoneA RelatedStoriesSupportUsComboInlineContentresponsive   uk-root fdn-margin-vert RelatedStoriesInlineContent comp-content-relatedstories" data-component-id="RelatedStoriesInlineContent">
<div micro-component>
<div class="MicroComponent RelatedStoriesSupportUsComboInlineContentresponsive   uk-root fdn-margin-vert SupportUsExpandedState comp-shell-supportus" data-component-id="SupportUsExpandedState">
<div class="fdn-support-us-block">
<div class="fdn-support-us-start-row fdn-support-us-wrap">
<div class="uk-flex uk-flex-wrap uk-flex-center uk-width-4-5@s uk-width-1-1 fdn-support-us-flasher-row">
<h2 class="uk-margin-remove">I support</h2>
<div class="fdn-support-us-flasher-box uk-width-1-2@m uk-width-2-3">
<div uk-slider="autoplay: true;autoplay-interval: 710">
<div class="uk-slider-container">
<div class="uk-child-width-1-1 uk-slider-items">
<div class="fdn-slider-delayed">
<img src="/images/hou-main-logo.png" alt="Houston Press">
</div>
<div class="fdn-slider-delayed">
<img src="/images/hou-main-logo.png" alt="Houston Press">
</div>
<div>Local</div>
<div>Community</div>
<div>Journalism</div>
</div>
</div>
</div>
</div>
</div>
<div class="uk-flex uk-flex-center uk-flex-wrap fdn-support-us-start-row-text">
<div class="uk-margin-small-right uk-width-2-3@m uk-width-1-2@s uk-padding-small uk-padding-remove-vertical">
Support the independent voice of Houston and
help keep the future of the Houston Press free.
</div>
<div class="uk-padding-small fdn-support-us-support-button">
<a href="https://www.houstonpress.com/i-support" onclick="ga('send', 'event', 'VMG-Widget', 'Click', 'Music-Article-VMG-ISupport-Leader',  {'NonInteraction': 1});">
Support Us
</a>
</div>
</div>
</div>
<div class="fdn-support-us-toggle-row fdn-support-us-wrap" hidden>
<div class="uk-flex uk-flex-middle uk-flex-wrap uk-flex-center">
<div class="uk-margin-small-right">
<h2 class="uk-margin-remove-vertical uk-text-center">
Keep the Houston Press Free.
</h2>
</div>
<div class="uk-padding-small fdn-support-us-support-button">
<a href="https://www.houstonpress.com/i-support">Support Us</a>
</div>
</div>
</div>
<div class="fdn-support-us-toggle-button">
<a href="#" uk-toggle="target: .fdn-support-us-wrap">
<i class="fas fa-chevron-up fa-lg"></i>
</a>
</div>
</div>
</div>
</div>
<hidden hidden>
<br><br>
<div class="uk-margin-remove fdn-labeled uk-width-1-1 uk-flex uk-flex-around" fdn-ad-component>
<div apn-ad-hook="rectangle" display-targets="mobile">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</hidden>
<script>
  if (window.innerWidth < Foundation.ApnAds.tabletWidth) {
    jQuery('[data-component-id=RelatedStoriesInlineContent] [micro-component]').remove()
  }
  </script>
</div>
</div>
<br>
<br>
Browne has over 50 years of songs to draw upon, and was actually the headliner <a href="/music/jackson-browne-goes-deep-in-latest-swing-through-houston-7877805" target="_blank">the last time</a> he came through town. His set list this time was necessarily more abrupt, but even an arena environment can't dilute the urgency of his more powerful message songs, or the melancholy of his (many) songs about failed love.
<br>
<br>
He took the stage noting this concert had been "a long time comin'," not coincidentally leading into "I'm Alive," from the 1993 album of the same name. The set was a bit abbreviated, as befits the opener, and Browne himself remarked how "spooky" quiet the crowd was.
<br>
<br>
Blame that on his tendency to be democratic in his song choices (I'd like to hear "Lawyers in Love" performed live, just one time). Or perhaps it's how he's always managed to&nbsp;camouflage his darker themes in pop trappings, themes that take on an added poignancy as he (and his crowd) ages.<br>
<div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter"> <a href="https://media2.fdncms.com/hou/imager/u/original/12139196/hou_rocks_20211018_jamestaylor_02.jpeg" rel="contentImg_gal-12136457" title="Into the cool of the evening strolls the Pretender. - PHOTO BY JACK GORMAN" data-caption="<span>Into the cool of the evening strolls the Pretender.</span>&nbsp;&nbsp;            <em>Photo by Jack Gorman</em>" class="uk-display-block uk-position-relative uk-visible-toggle"> <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover"> click to enlarge </span> <img src="https://media2.fdncms.com/hou/imager/u/blog/12139196/hou_rocks_20211018_jamestaylor_02.jpeg?cb=1634559015" alt="Into the cool of the evening strolls the Pretender. - PHOTO BY JACK GORMAN" width="760" height="474" /> </a> <div class="fdn-caption-block uk-margin-auto" style="max-width: 760px"> <div class="fdn-image-caption"> Into the cool of the evening strolls the Pretender. </div> <div class="fdn-image-credit"> Photo by Jack Gorman </div> </div> </div> The crowd certainly perked up when Taylor emerged to join Browne for "The Pretender," setting the tone for the rest of the evening. Last night's opener has always struck more of a chord with me personally, while Taylor seemed to come across as more of an elder statesman. Blame Browne's perceived Los Angeles insouciance against what Garry Trudeau once described as "that Martha's Vineyard sound," or how Taylor's music seems lodged squarely in the 1970s.
<br>
<br>
If it ain't broke, as the saying goes, don't fix it. Taylor and his All-Star Band (including "Blue" Lou Marini on sax, Michito Sanchez and Steve Gadd on percussion/drums, and Taylor's son Henry on backing vocals) eased through a familiar set, punctuated liberally with the expected hits while only showcasing one&nbsp;cut off <i>American Standard</i>&nbsp;(the Johnnie "Scat" Davis cover&nbsp;"As Easy as Rolling Off a Log").
<hidden hidden>
<div class="uk-padding-remove fdn-override-width-1-1">
<br><br>
<div class="ZoneA AirMediumRectangleInlineContentMobileDisplaySizeresponsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirMediumRectangleInlineContentMobileDisplaySize comp-" data-component-id="AirMediumRectangleInlineContentMobileDisplaySize" fdn-ad-component>
<div apn-ad-hook="rectangle" display-targets="mobile">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</div>
</hidden>
<br>
<br>
The show was a little front-loaded with anecdotes, as Taylor set a scene for "You Make it Easy" (a smoky bar at 2:30 a.m., when one's judgment is always at its finest), or talking about his Carolina upbringing for — wait for it — "Copperline." Maybe I've missed out, but surely there are stories to tell about the big hits? The back half of his set seemed almost rushed by comparison.
<hidden hidden>
<div class="uk-padding-remove fdn-override-width-1-1">
<div class="ZoneA AirBillboardInlineContentresponsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirBillboardInlineContent comp-" data-component-id="AirBillboardInlineContent" inline-content-billboard style="width:1040px;" fdn-ad-component>
<div class="uk-visible@m uk-flex uk-flex-row uk-width-1-1 uk-flex uk-flex-center" style="
      width:1040px;
      border-top: thin solid #ccc;
      margin-top: 30px !important;
      padding-top: 30px;
      border-bottom: thin solid #ccc; 
      margin-bottom: 0px;
      padding-bottom: 30px;">
<div apn-ad-hook="billboard" display-targets="desktop|tablet">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</div>
</div>
</hidden>
<br>
<br>
And then there was "Steamroller."
<br>
<br>
It's been a staple of his live sets since 1969, but traditions aren't always a good thing. Kind of awkward back then, Taylor's grimacing and mugging last night threatened to discombobulate the entire affair. Fortunately, "Fire and Rain," "Carolina in My Mind," and the others were right around the corner.
<br>
<br>
Taylor's production was surprisingly elaborate, with an engaging video presentation and a giant oak tree that loomed over the stage with multi-colored lanterns that dipped and rose as the music required. It served its purpose, conferring a pastoral, comforting presence on music that's already pretty soothing.
<hidden hidden>
<div class="uk-padding-remove fdn-override-width-1-1">
<br><br>
<div class="ZoneA AirMediumRectangleInlineContentMobileDisplaySize2responsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirMediumRectangleInlineContentMobileDisplaySize2 comp-" data-component-id="AirMediumRectangleInlineContentMobileDisplaySize2" fdn-ad-component>
<div apn-ad-hook="rectangle" display-targets="mobile">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</div>
</hidden>
<br>
<br>
The singer also enjoyed some back and forth with the audience, responding to repeated cries of "I love you" with reminders that he's happily married (third time's a charm) and wisely not pursuing a conversational thread about his Red Sox and the Astros.
<br>
<br>
But this wasn't a crowd spoiling for a fight. Indeed, judging by the reaction to the closing numbers, and to Browne joining for an encore that included "Take It Easy" and "You've Got A Friend," both artists proved they still have what it takes to bring the house down. Not that there's any way to tell how much of that&nbsp;was a reaction to finally getting to see this show after it was postponed twice due to COVID.
<br>
<br>
Judging by the attendees, a lingering pandemic was less of a priority than filming large chunks of the show with the flashlight app on full blast.<i><br>
</i> <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter"> <a href="https://media2.fdncms.com/hou/imager/u/original/12139436/hou_rocks_20211018_jamestaylor_03.jpeg" rel="contentImg_gal-12136457" title="James Taylor and his Large Band. - PHOTO BY JACK GORMAN" data-caption="<span>James Taylor and his Large Band.</span>&nbsp;&nbsp;            <em>Photo by Jack Gorman</em>" class="uk-display-block uk-position-relative uk-visible-toggle"> <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover"> click to enlarge </span> <img src="https://media2.fdncms.com/hou/imager/u/blog/12139436/hou_rocks_20211018_jamestaylor_03.jpeg?cb=1634559015" alt="James Taylor and his Large Band. - PHOTO BY JACK GORMAN" width="760" height="474" /> </a> <div class="fdn-caption-block uk-margin-auto" style="max-width: 760px"> <div class="fdn-image-caption"> James Taylor and his Large Band. </div> <div class="fdn-image-credit"> Photo by Jack Gorman </div> </div> </div> <b>Personal Bias:</b>&nbsp;My parents had a copy of <i>Sweet Baby James</i>, as required by the Articles of Boomer Confederation. I still prefer his <i>Simpsons </i>appearance.
<br>
<br>
<b>The Crowd:</b>&nbsp;Old and bald enough it could've been a James Taylor cosplay convention.
<br>
<br>
<b>Overheard In The Crowd:</b>&nbsp;"Free Bird!"
<br>
<br>
<b>Random Notebook Dump:</b>&nbsp;"Who the fuck still yells 'Free Bird!' in 2021?"
<br>
<br>
<b>JACKSON BROWNE SET LIST</b><br>
I'm Alive<br>
Rock Me on the Water<br>
Long Way Around<br>
Fountain of Sorrow<br>
Downhill from Everywhere<br>
The Dreamer<br>
Call It A Loan<br>
Doctor, My Eyes<br>
The Pretender<br>
Running On Empty
<br>
<br>
<br>
<b>JAMES TAYLOR SET LIST</b><br>
Country Road<br>
Copperline<br>
That's Why I'm Here<br>
Mexico<br>
You Make It Easy<br>
Line 'Em Up<br>
Steamroller<br>
Easy as Rollin' Off a Log (Johnnie ‘Scat’ Davis cover)<br>
Sweet Baby James<br>
Fire and Rain<br>
Carolina in My Mind<br>
Shower the People<br>
How Sweet It Is (To Be Loved by You) (Marvin Gaye cover)
<br>
<br>
<b>ENCORE</b><br>
Shed a Little Light<br>
Take It Easy (Eagles cover)<br>
You've Got a Friend (Carole King cover)<br>
You Can Close Your Eyes
</div>
</div>
</div>
</div>
<div class="uk-width-1-1">
<div class="ZoneA KeepFreeresponsive   uk-root fdn-margin-vert KeepFree comp-content-keepfree" data-component-id="KeepFree">
<div class="uk-position-relative uk-overflow-hidden">
<div class="fdn-keep-free-blue-bar-top" uk-scrollspy="cls: fdn-animation-blue-bar-top; delay: 300;"></div>
<div class="fdn-keep-free-blue-bar-left" uk-scrollspy="cls:fdn-animation-blue-bar-left; delay:1500"></div>
<div class="fdn-keep-free-body">
<strong>KEEP THE HOUSTON PRESS FREE...</strong>
Since we started the <i>Houston Press</i>, it has been defined as the free, independent voice of Houston, and we'd like to keep it that way. With local media under siege, it's more important than ever for us to rally support behind funding our local journalism. You can help by participating in our "I Support" program, allowing us to keep offering readers access to our incisive coverage of local news, food and culture with no paywalls.
</div>
<div class="uk-position-relative fdn-keep-free-link">
<a href="https://www.houstonpress.com/i-support" onclick="ga('send', 'event', 'VMG-Widget', 'Click', 'Music-VMG-ISupport-AfterArticle',  {'NonInteraction': 1});">
Make a one-time donation today for as little as $1.
</a>
<div class="fdn-keep-free-text-mask" uk-scrollspy="cls:fdn-animation-text-mask"></div>
</div>
</div>
</div>
<div class="ZoneA AbouttheAuthorCustomresponsive   uk-root fdn-margin-vert AbouttheAuthorCustom comp-content-abouttheauthor" data-component-id="AbouttheAuthorCustom">
<div class="uk-flex uk-margin-xsmall-bottom">
<div class="uk-width-1-4 uk-flex uk-flex-center uk-flex-middle uk-padding-xsmall-right fdn-about-author-image-block">
<a class="no-foundation-imgeditor uk-display-block" href="https://www.houstonpress.com/author/pete-vonder-haar">
<img uk-img="" data-src="/imager/b/r-bigsquare/6357169/34c1/petevdh_headhori.jpg" alt="" width="400" height="400" class="memberThumb uk-border-circle" />
</a>
</div>
<div class="uk-width-expand fdn-about-author-content-block">
<div class="bio">
<b>Peter Vonder Haar</b> writes movie reviews for the <i>Houston Press</i> and the occasional book. The first three novels in the "Clarke & Clarke Mysteries" - <i>Lucky Town</i>, <i>Point Blank</i>, and <i>Empty Sky</i> - are out now.
</div>
<div class="contact">
<strong class="uk-text-uppercase">Contact:</strong>
<a href="https://posting.houstonpress.com/about/contact?to=6357169">Pete Vonder Haar</a>
</div>
<div class="uk-flex uk-flex-middle uk-flex-wrap follow">
<strong class="uk-text-uppercase uk-margin-xsmall-right">Follow:</strong>
<div>
<span>Twitter:</span>
<a href="https://twitter.com/PeterVonderHaar" target="_blank">
@PeterVonderHaar
</a>
</div>
</div>
</div>
</div>
</div>
<div id="Yieldmo-ym_927391772937231496-12136457"></div>
<script>
  var Foundation = window.Foundation || (window.Foundation = {});
  Foundation.Yieldmo = (typeof(Foundation.Yieldmo) === 'undefined') ? {} : Foundation.Yieldmo;
  Foundation.Yieldmo.unique_id = (typeof(Foundation.Yieldmo.unique_id) === 'undefined') ? Date.now() : Foundation.Yieldmo.unique_id;
  jQuery('#Yieldmo-ym_927391772937231496-12136457').html(`
    <div id="ym_927391772937231496" class="ym ym_scroll" data-id="12136457-${Foundation.Yieldmo.unique_id}"></div>
  `);
  
</script>
<script type="text/javascript">
  (function(e,t){if(t._ym===void 0){t._ym="";var m=e.createElement("script");m.type="text/javascript",m.async=!0,m.src="//static.yieldmo.com/ym.min.js",(e.getElementsByTagName("head")[0]||e.getElementsByTagName("body")[0]).appendChild(m)}else t._ym instanceof String||void 0===t._ym.chkPls||t._ym.chkPls()})(document,window);
</script>
<div class="uk-width-1-1 uk-flex uk-flex-row uk-flex-wrap fdn-content-footer-row">
<div class="uk-first-column text-links-hook">
<div class="ZoneA SailthruRecommendationsresponsive  uk-width-medium@s uk-margin-remove SailthruRecommendations-12136457 uk-root fdn-margin-vert SailthruRecommendations comp-content-sailthrurecommendations" data-component-id="SailthruRecommendations">
<h3 class="uk-margin-remove uk-heading-line uk-text-uppercase">
<span>
Trending Music
</span>
</h3>
<ul class="uk-list fdn-list-bullet" sailthru-hook>
<li><a href="https://www.houstonpress.com/music/top-10-butt-rock-bands-of-all-time-6519109" data-objid="6519109" title="Top 10 Butt-Rock Bands of All Time">Top 10 Butt-Rock Bands of All Time</a></li>
<li><a href="https://www.houstonpress.com/music/things-to-do-listen-to-stomping-ground-by-dion-12098539" data-objid="12098539" title="Dion Goes Wandering Around the Blues [UPDATED]">Dion Goes Wandering Around the Blues [UPDATED]</a></li>
<li><a href="https://www.houstonpress.com/music/the-five-most-repellent-things-ted-nugent-has-ever-done-6756533" data-objid="6756533" title="The Five Most Repellent Things Ted Nugent Has Ever Done">The Five Most Repellent Things Ted Nugent Has Ever Done</a></li>
<li><a href="https://www.houstonpress.com/music/the-10-most-overplayed-songs-at-mexican-weddings-texas-edition-6775520" data-objid="6775520" title="The 10 Most Overplayed Songs at Mexican Weddings, Texas Edition">The 10 Most Overplayed Songs at Mexican Weddings, Texas Edition</a></li>
</ul>
<hidden hidden>
<ul class="uk-list fdn-list-bullet">
<li>
<div class="ZoneA AirNativeArticleresponsive   uk-root fdn-margin-vert AirNativeArticle comp-" data-component-id="AirNativeArticle">
<div apn-ad-hook="nativeArticle" display-targets="desktop|tablet|mobile">
<div class="xandr-text-only">

<div class="xandr-txt-wrapper">

<span class="xandr-sponsored-by">Presented by: [%sponsoredBy%]</span>

<h1 class="xandr-title">[%title%]</h1>
</div>
</div>
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</li>
</ul>
</hidden>
<script>
      jQuery(document).ready(function($) {

        Sailthru.personalize({
          "sections": [
        
          {
            "id":  "8a469086-a12f-11e6-88be-002590d1a41a",
            "selector": ".SailthruRecommendations-12136457 > ul[sailthru-hook]",
            "onSuccess":  function(response) {
              Foundation.SailthruSPM.Personalize({
                "selector": ".SailthruRecommendations-12136457 > ul[sailthru-hook]", 
                "data": response,
                
                  "count": 4,
                
                "template": (article) => `<li><a href="${article.url}" data-objid="${article.vars.objid}" title="${article.title}">${article.title}</a></li>`
              });
            }
          }
        
      ],
          "vars": {
            "placed": "12136457"  
          }
        });
      });
    </script>
</div>
</div>
<div class="uk-width-expand@s fdn-content-placeholder avantis-hook">
<div class="ZoneA ConnatixPlayerContentQueryDynamicresponsive  uk-width-1-1 uk-flex uk-flex-center uk-margin-remove-top uk-root fdn-margin-vert ConnatixPlayerContentQueryDynamic comp-" data-component-id="ConnatixPlayerContentQueryDynamic">
<script id="ConnatixPlayerContentQueryDynamic-12136457">
            console.log('connatix widget', document.currentScript)
            if(typeof cnxps != "undefined") {
              cnxps.cmd.push(function () {
                cnxps({
                  playerId: '825370cc-74e5-40cb-a0ea-f3c658f05a13'
                }).render('ConnatixPlayerContentQueryDynamic-12136457');
              });
            }
          </script>
</div>
</div>
</div>
<div class="ZoneA NewsletterSignup657responsive   uk-root fdn-margin-vert NewsletterSignup657 comp-newsletter-newslettersignup" data-component-id="NewsletterSignup657">
<div class="uk-flex uk-flex-wrap uk-width-1-1 fdn-newsletter-signup-medium">
<div class="uk-flex uk-flex-wrap fdn-newsletter-signup-main">
<div class="fdn-newsletter-signup-logo">
<img src="/images/air/newsletter-icon-hou.png" alt="">
</div>
<div class="uk-flex uk-flex-wrap fdn-newsletter-signup-text-block">
<div class="fdn-newsletter-signup-text">
<div class="fdn-newsletter-signup-text-large-only">
Don't Miss Out
</div>
<strong>SIGN UP</strong> for the latest
Music
news, free stuff and more!
</div>
<div class="fdn-newsletter-signup-button-block">
<div class="pelcro-logged-out">
<a href="#newsletterSignUp" class="pelcro-subscribe-button fdn-newsletter-signup-button" data-product-id="540" data-vmgs-psource="In-Article Sign Up|Music" data-vmgs-section="Music" onCLick="ga('send', 'event', 'VMG-Widget', 'Click', 'In-Article Sign Up-Music', {'NonInteraction': 1});">
Join Today <i class="fas fa-caret-right"></i>
</a>
</div>
<div class="pelcro-logged-in">
<a href="/profile" class="fdn-newsletter-signup-button" onCLick="ga('send', 'event', 'VMG-Widget', 'Click', 'In-Article Sign Up-Music', {'NonInteraction': 1});">
Sign Up
</a>
</div>
</div>
</div>
</div>
<div class="uk-flex uk-flex-wrap fdn-newsletter-signup-secondary">
<div class="fdn-newsletter-signup-secondary-text">
Become a member to support the independent voice of Houston
and help keep the future of the Houston Press <strong>FREE</strong>
</div>
<div class="fdn-newsletter-signup-secondary-link-block uk-flex uk-flex-wrap uk-flex-middle uk-width-1-1">
<a href="/i-support" class="fdn-newsletter-signup-secondary-link">I Support
<img src="/images/hou-main-logo.png" alt="Houston Press">
</a>
<a href="/i-support" class="fdn-newsletter-signup-secondary-link-learn-more">Learn More</a>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="uk-width-auto uk-visible@sm uk-margin-left" style="width: 300px;" distribute-right-column-items>
<div class="beforeBillboard uk-flex uk-flex-column">
<div class="stickCeption1" style="z-index: 10;" uk-sticky="
           offset: 95;
           bottom: true;">
<script id="fdncms-carousel-top-stories-video" src="https://www.hub.fdncms.com/gyrobase/Responsive/Components/Content/TopStoriesVideo?key=4c13beaef3305ae21a81a3df96a5343e&req=js&pid=music" async></script>
</div>
<div class="stickCeption2 uk-margin-remove" style="z-index: 1;" uk-sticky="
           offset: 390;
           bottom: true;">
<hidden hidden>
<div class="ZoneA AirRectangleTopRightColumnresponsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirRectangleTopRightColumn comp-" data-component-id="AirRectangleTopRightColumn" fdn-ad-component>
<div apn-ad-hook="tower" display-targets="desktop">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</hidden>
</div>
</div>
<div class="billboardSpacer" style="pointerEvents: none;"></div>
<div class="afterBillboard uk-flex uk-flex-column">
<div class="stickCeption" style="z-index: 1;" uk-sticky="
           offset: 95;
           bottom: true;">
<div class="ZoneA LatestInCategoryresponsive  fdn-component-related-items uk-root fdn-margin-vert LatestInCategory comp-content-latestincategory" data-component-id="LatestInCategory">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Latest Stories
</h3>
</div>
<ul class="pres-ContentListSquareBrief uk-list uk-list-divider">
<li class="">
<div class="uk-flex">
<div class="uk-flex-1 uk-margin-remove">
<a href="https://www.houstonpress.com/music/things-to-do-listen-to-stomping-ground-by-dion-12098539">
<p class="fdn-teaser-headline">
Dion Goes Wandering Around the Blues [UPDATED]
</p>
</a>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Bob Ruggiero
</p>
<time>
Oct 15, 2021
</time>
</div>
</div>
<div class="fdn-pres-image uk-width-1-3 uk-width-1-4@exs uk-flex-first">
<a href="https://www.houstonpress.com/music/things-to-do-listen-to-stomping-ground-by-dion-12098539">
<img uk-img="" data-src="https://media2.fdncms.com/hou/imager/u/r-bigsquare/12098543/hou_mus_dion_copy.jpg?cb=1634319427" alt="Dion: King of the New York Streets" width="400" height="400" class="" />
</a>
</div>
</div>
</li>
<li class="">
<div class="uk-flex">
<div class="uk-flex-1 uk-margin-remove">
<a href="https://www.houstonpress.com/music/things-to-do-johnny-falstaff-welcome-home-shows-12106359">
<p class="fdn-teaser-headline">
Honky Tonkin' Daddy Johnny Falstaff Returns
</p>
</a>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Gladys Fuentes
</p>
<time>
Oct 14, 2021
</time>
</div>
</div>
<div class="fdn-pres-image uk-width-1-3 uk-width-1-4@exs uk-flex-first">
<a href="https://www.houstonpress.com/music/things-to-do-johnny-falstaff-welcome-home-shows-12106359">
<img uk-img="" data-src="https://media1.fdncms.com/hou/imager/u/r-bigsquare/12117045/johnny_falstaff.jpg?cb=1634215779" alt="Johnny Falstaff is getting a big hometown welcome with three gigs around town this month to kick off his return." width="400" height="400" class="" />
</a>
</div>
</div>
</li>
<li class="">
<div class="uk-flex">
<div class="uk-flex-1 uk-margin-remove">
<a href="https://www.houstonpress.com/music/review-king-of-the-blues-the-rise-and-reign-of-bb-king-12074903">
<p class="fdn-teaser-headline">
The Trailblazing Reign of B.B. King
</p>
</a>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Tom Richards
</p>
<time>
Oct 14, 2021
</time>
</div>
</div>
<div class="fdn-pres-image uk-width-1-3 uk-width-1-4@exs uk-flex-first">
<a href="https://www.houstonpress.com/music/review-king-of-the-blues-the-rise-and-reign-of-bb-king-12074903">
<img uk-img="" data-src="https://media1.fdncms.com/hou/imager/u/r-bigsquare/12097043/bb_king_onstage.jpg?cb=1634059239" alt="B.B. King on stage in 2007, toward the end.  It was a difficult period for both the guitarist and his audience." width="400" height="400" class="" />
</a>
</div>
</div>
</li>
</ul>
<div class="uk-margin-small uk-clearfix uk-text-right ">
<a class="uk-align-right uk-margin-remove fdn-more-link uk-flex-inline uk-flex-middle" href="https://www.houstonpress.com/houston/ArticleArchives?category=6357953">
More &raquo;
</a>
</div>
</div>
<div class="ZoneA AirAvantisRightColBelowBillboardresponsive  uk-margin-remove-top uk-margin-medium-bottom uk-root fdn-margin-vert AirAvantisRightColBelowBillboard comp-shell-avantis" data-component-id="AirAvantisRightColBelowBillboard">
<div id="avantis-test-1" class="avantis"></div>
</div>
<hidden hidden>
<div class="ZoneA AirMediumRectangleRightColBelowBillboardresponsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirMediumRectangleRightColBelowBillboard comp-" data-component-id="AirMediumRectangleRightColBelowBillboard" fdn-ad-component>
<div apn-ad-hook="rectangle" display-targets="desktop">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</hidden>
</div>
</div>
</div>
</div>
</div>
<hidden hidden>
<div class="ZoneA AirLeaderboardBetweenContentresponsive  uk-margin-small uk-width-1-1 fdn-labeled uk-flex uk-flex-row uk-flex-around uk-root fdn-margin-vert AirLeaderboardBetweenContent comp-" data-component-id="AirLeaderboardBetweenContent" fdn-ad-component>
<div apn-ad-hook="leaderboardBetweenContent" display-targets="desktop|mobile">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</hidden>
<div class="content-multiple-item" fdn-content-multi-item="12139445" fdn-content-multi-item-headline="Last Night: Maluma At Smart Financial Centre" fdn-content-multi-item-permalink="/music/review-maluma-at-smart-financial-centre-10-17-21-12139445" fdn-content-multi-item-canonical="https://www.houstonpress.com/music/review-maluma-at-smart-financial-centre-10-17-21-12139445" fdn-content-multi-item-title="Last Night: Maluma At Smart Financial Centre" fdn-content-multi-item-thumb="https://media2.fdncms.com/hou/imager/u/slideshow/12139676/hou_mus_20211018_maluma_marcotorres_0005.jpg?cb=1634541812" fdn-content-multi-item-thumb-width="1524" fdn-content-multi-item-thumb-height="1016" ga-dimension2="Music" ga-dimension3="12139445" ga-dimension4="2021-10-18 06:46:00" ga-dimension5="Concerts%Music" ga-dimension6="Matthew Keever" ga-dimension7="Articles" fdn-content-multi-item-loader="fetch">
</div>
<hidden hidden>
<div class="ZoneA AirLeaderboardBetweenContentresponsive  uk-margin-small uk-width-1-1 fdn-labeled uk-flex uk-flex-row uk-flex-around uk-root fdn-margin-vert AirLeaderboardBetweenContent comp-" data-component-id="AirLeaderboardBetweenContent" fdn-ad-component>
<div apn-ad-hook="leaderboardBetweenContent" display-targets="desktop|mobile">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</hidden>
<div class="content-multiple-item" fdn-content-multi-item="12096329" fdn-content-multi-item-headline="Riff-Arific Egg Drop Soup is Brazenly Impenitent and We&#39;re Here for It" fdn-content-multi-item-permalink="/music/things-to-do-egg-drop-soup-pachinko-hut-october-20-2021-12096329" fdn-content-multi-item-canonical="https://www.houstonpress.com/music/things-to-do-egg-drop-soup-pachinko-hut-october-20-2021-12096329" fdn-content-multi-item-title="Riff-Arific Egg Drop Soup is Brazenly Impenitent and We&#39;re Here for It" fdn-content-multi-item-thumb="https://media1.fdncms.com/hou/imager/u/slideshow/12096332/eggdrop81.jpg?cb=1634209539" fdn-content-multi-item-thumb-width="1524" fdn-content-multi-item-thumb-height="941" ga-dimension2="Music" ga-dimension3="12096329" ga-dimension4="2021-10-18 04:00:00" ga-dimension5="Music%Rock%Things To Do" ga-dimension6="Jesse Sendejas Jr." ga-dimension7="Articles" fdn-content-multi-item-loader="fetch">
</div>
<hidden hidden>
<div class="ZoneA AirLeaderboardBetweenContentresponsive  uk-margin-small uk-width-1-1 fdn-labeled uk-flex uk-flex-row uk-flex-around uk-root fdn-margin-vert AirLeaderboardBetweenContent comp-" data-component-id="AirLeaderboardBetweenContent" fdn-ad-component>
<div apn-ad-hook="leaderboardBetweenContent" display-targets="desktop|mobile">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</hidden>
<script src="https://code.jquery.com/jquery-1.12.4.min.js" integrity="sha256-ZosEbRLbNQzLpnKIkEdrPv7lOy9C27hHQ+Xp8a4MxAQ=" crossorigin="anonymous"></script>
<script>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</script>
</div>
</div>
</div>
<div class="ev-grid-zone ev-column-zone uk-flex uk-flex-wrap uk-child-width-1-2@m">
<div class="ev-grid-col" data-ev-zone="ZoneB">
</div>
<div class="ev-grid-col" data-ev-zone="ZoneC">
</div>
</div>
<div class="ev-grid-zone ev-secondary-zone" data-ev-zone="ZoneD">
<div class="ev-grid-col uk-width-1-1">
</div>
</div>
<div class="ev-grid-zone ev-footer-zone" data-ev-zone="GlobalFooter">
<div class="ev-grid-col uk-width-1-1">
<div class="GlobalFooter ContentDefaultMultiple   uk-root fdn-margin-vert CookieConsent comp-shell-cookieconsent" data-component-id="CookieConsent">
<link rel="stylesheet" type="text/css" href="https://cdn.jsdelivr.net/npm/cookieconsent@3/build/cookieconsent.min.css" />
<script src="https://cdn.jsdelivr.net/npm/cookieconsent@3/build/cookieconsent.min.js" data-cfasync="false"></script>
<script>
  window.cookieconsent.initialise({
    "palette": {
      "popup": {
        "background": "#000"
      },
      "button": {
        "background": "#f1d600"
      }
    },
    "content": {
      
        "message": "We use cookies to collect and analyze information \n  on site performance and usage, and to enhance and \n  customize content and advertisements. \n  By clicking 'Got it' or continuing to use the site, \n  you agree to allow cookies to be placed. \n  To find out more, visit our \n  <a href=\"\/about\/cookies\">cookies policy<\/a> and our \n  <a href=\"\/about\/privacy-policy\">privacy policy<\/a>.",
      
      

      
        "link": "",
        "href": ""
      
    }
  });
  </script>
</div>
<div class="GlobalFooter ContentDefaultMultiple   uk-root fdn-margin-vert NewsletterModal comp-newsletter-newslettermodal" data-component-id="NewsletterModal">
<div id="NewsletterModal" class="uk-flex-top" uk-modal>
<div class="uk-modal-dialog uk-modal-body uk-padding-remove">
<div class="uk-flex uk-flex-right">
<button class="uk-modal-close-default uk-position-top-right" type="button" uk-close onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'CloseX', {'nonInteraction': 1});"></button>
</div>
<div class="uk-flex fdn-newsletter-modal-wrap">
<div class="fdn-newsletter-modal-left uk-flex uk-flex-middle">
<p class="uk-margin-auto">Join the Houston Press community and help support
independent local journalism in Houston.</p>
</div>
<div class="fdn-newsletter-modal-right uk-flex-1 uk-flex uk-flex-column uk-flex-wrap uk-padding-small">
<div class="fdn-newsletter-modal-logo uk-flex uk-flex-bottom uk-margin-medium-top uk-margin-medium uk-margin-small">
<img src="/images/hou-main-logo.png" alt="Houston Press">
<span>Insiders</span>
</div>
<div class="fdn-newsletter-modal-text-block uk-margin-xsmall">
<p class="uk-margin-xsmall">
Get the latest updates in news, food, music and culture, and receive special offers direct to your inbox.
</p>
<div class="uk-flex uk-flex-wrap fdn-newsletter-modal-sign-up-block">
<a href="#newsletterSignUp" class="pelcro-subscribe-button fdn-newsletter-modal-sign-up-link" data-product-id="" data-vmgs-psource="Pop Up|Music" data-vmgs-section="Music" onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'Music', {'NonInteraction': 1});">
Sign Up Now <i class="far fa-sm fa-chevron-right"></i>
</a>
<a href="#noThanks" class="fdn-newsletter-modal-no-thanks-link uk-modal-close" onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'NoThanks', {'nonInteraction': 1});">
No Thanks
</a>
</div>
</div>
<div class="fdn-newsletter-modal-text-block uk-margin-xsmall">
<p class="uk-margin-xsmall">
Become a member and go ad-free!
</p>
<div class="uk-flex uk-width-1-1">
<a href="/i-support" class="fdn-newsletter-modal-support-link" onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'Pelcro-Support', {'NonInteraction': 1});">
Support Our Journalism <i class="far fa-sm fa-chevron-right"></i>
</a>
</div>
</div>
<div class="fdn-newsletter-modal-footer uk-text-right uk-margin-auto-top">
<a href="/about/privacy-policy" target="_blank">Privacy Policy</a>
</div>
</div>
</div>
</div>
</div>
<script>
  jQuery(document).on('PelcroSiteLoaded', function (e) {
    var modalElement = jQuery('#NewsletterModal')

    var modalCookieKey = 'fdn_nlmc'
    var modalCookieValue = null
    var modalCookieValueDisplayed = 'displayed'
    var modalCookieValueClosed = 'CloseX'
    var modalCookieValueNoThanks = 'NoThanks'

    var closeForDays = 15
    var closeForDaysInSeconds = 60 * 60 * 24 * closeForDays
    var closeForDaysMaxAge = 'max-age=' + closeForDaysInSeconds

    var dateNow = new Date()
    var dateInTwoCenturies = new Date(dateNow.setFullYear(dateNow.getFullYear() + 200))
    var dateExpiresLongTime = 'expires=' + dateInTwoCenturies

    var cookieList = document.cookie.split('; ')
    var modalCookie = cookieList.find(item => item.startsWith(modalCookieKey))

    if (modalCookie) {
      modalCookieValue = modalCookie.split('=')[1]
    }

    var alreadyShown = new RegExp(`^${modalCookieValueDisplayed}|${modalCookieValueClosed}|${modalCookieValueNoThanks}$`)

    var modalTimeout = setTimeout(function () {
      if (window.Foundation && Foundation.Pelcro && Foundation.Pelcro.init) {
        // Make sure pelcro is ready so signup links work
        if (typeof(Pelcro) === "object") {
          if (modalCookieValue && modalCookieValue?.match(alreadyShown)) {
            // console.log('Newsletter signup modal already displayed.')
            return
          }
          else {
            UIkit.modal(modalElement).show();
            document.cookie = `${modalCookieKey}=${modalCookieValueDisplayed}`
          }
        }
      }
    }, 5000)

    modalElement.on('click', '[uk-close]', function () {
      document.cookie = `${modalCookieKey}=${modalCookieValueClosed}; ${closeForDaysMaxAge}`
    })

    modalElement.on('click', '[href="#noThanks"]', function () {
      document.cookie = `${modalCookieKey}=${modalCookieValueNoThanks}; ${dateExpiresLongTime}`
    })

    // modalElement.on('click', '[href=#newsletterSignUp]', function () {
    //   UIkit.modal(modalElement).hide()
    // })
  })
  </script>
</div>
<style>
.uk-root .fdn-custom-footer-navigation-link-block-wide-columns > * {width:25%;}
</style>
<div class="GlobalFooter ContentDefaultMultiple  uk-margin-remove uk-root fdn-margin-vert SiteFooterCustom comp-shell-sitefooter" data-component-id="SiteFooterCustom">
<div class="fdn-custom-footer-navigation-link-block fdn-custom-footer-navigation-link-block-wide uk-visible@s">
<div class="uk-flex uk-child-width-1-5 fdn-custom-footer-navigation-link-block-wide-columns">
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="https://www.houstonpress.com/" title="" onclick="ga(" send", "event", "Nav", "Click", "Editorial")">
Editorial
</a>
</li>
<li>
<a href="https://www.houstonpress.com/" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Homepage")" title="">
Homepage
</a>
</li>
<li>
<a href="https://www.houstonpress.com/news" target="_self" onclick="ga(" send", "event", "Nav", "Click", "News")" title="">
News
</a>
</li>
<li>
<a href="https://www.houstonpress.com/restaurants" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Food & Drink")" title="">
Food &amp; Drink
</a>
</li>
<li>
<a href="https://www.houstonpress.com/arts" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Arts & Culture")" title="">
Arts &amp; Culture
</a>
</li>
<li>
<a href="https://www.houstonpress.com/music" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Music")" title="">
Music
</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="https://www.houstonpress.com/promotions" title="" onclick="ga(" send", "event", "Nav", "Click", "Marketing")">
Marketing
</a>
</li>
<li>
<a href="https://www.houstonpress.com/coupons" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Coupons")" title="">
Coupons
</a>
</li>
<li>
<a href="https://www.houstonpress.com/profile?newsletter=11582352" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Promotions Newsletter")" title="">
Promotions Newsletter
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/flipbooks" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Flipbook Archive")" title="">
Flipbook Archive
</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="https://www.houstonpress.com/about" title="" onclick="ga(" send", "event", "Nav", "Click", "More")">
More
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about" target="_self" onclick="ga(" send", "event", "Nav", "Click", "About Us")" title="">
About Us
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/staff" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Staff")" title="">
Staff
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/careers" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Houston Press Careers")" title="">
Houston Press Careers
</a>
</li>
<li>
<a href="https://www.houstonpress.com/advertise" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Local Advertising")" title="">
Local Advertising
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/terms-of-use" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Terms of Use")" title="">
Terms of Use
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/privacy-policy" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Privacy Policy")" title="">
Privacy Policy
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/contact" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Contact Us")" title="">
Contact Us
</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="#" title="" onclick="ga(" send", "event", "Nav", "Click", "Back to Top")" uk-totop uk-scroll>
Back to Top
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/californiaPrivacyPolicy" target="_self" onclick="ga(" send", "event", "Nav", "Click", "California Privacy Policy")" title="">
California Privacy Policy
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/californiaPrivacyPolicy#CollectionNotice" target="_self" onclick="ga(" send", "event", "Nav", "Click", "California Collection Notice")" title="">
California Collection Notice
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/californiaPrivacyPolicy#DoNotSell" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Do Not Sell My Info")" title="">
Do Not Sell My Info
</a>
</li>
</ul>
<div class="fdn-custom-footer-navigation-link-social-block">
<a class="fdn-custom-footer-navigation-link-social-facebook" href="https://www.facebook.com/HoustonPress" onclick="ga(" send", "event", "Nav", "Click", "Facebook")" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-facebook"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-instagram" href="https://instagram.com/houstonpress" onclick="ga(" send", "event", "Nav", "Click", "Instagram")" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-instagram"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-twitter" href="https://twitter.com/houstonpress" onclick="ga(" send", "event", "Nav", "Click", "Twitter")" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-twitter"></i>
</a>
</div>
</div>
</div>
</div>
<div class="fdn-custom-footer-navigation-link-block fdn-custom-footer-navigation-link-block-narrow uk-hidden@s">
<div class="fdn-custom-footer-navigation-link-block-narrow-rows">
<div class="fdn-custom-footer-navigation-link-block-row">
<ul class="uk-nav-default uk-nav-parent-icon" uk-nav="multiple: false">
<li class="uk-parent">
<a href="https://www.houstonpress.com/" target="_self" class="fdn-custom-footer-navigation-link-block-row-header">
Editorial
</a>
<ul class="uk-nav-sub uk-child-width-1-2 uk-flex uk-flex-wrap">
<li>
<a href="https://www.houstonpress.com/" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Homepage")" title="">
Homepage
</a>
</li>
<li>
<a href="https://www.houstonpress.com/news" target="_self" onclick="ga(" send", "event", "Nav", "Click", "News")" title="">
News
</a>
</li>
<li>
<a href="https://www.houstonpress.com/restaurants" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Food & Drink")" title="">
Food &amp; Drink
</a>
</li>
<li>
<a href="https://www.houstonpress.com/arts" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Arts & Culture")" title="">
Arts &amp; Culture
</a>
</li>
<li>
<a href="https://www.houstonpress.com/music" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Music")" title="">
Music
</a>
</li>
</ul>
</li>
<li class="uk-parent">
<a href="https://www.houstonpress.com/promotions" target="_self" class="fdn-custom-footer-navigation-link-block-row-header">
Marketing
</a>
<ul class="uk-nav-sub uk-child-width-1-2 uk-flex uk-flex-wrap">
<li>
<a href="https://www.houstonpress.com/coupons" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Coupons")" title="">
Coupons
</a>
</li>
<li>
<a href="https://www.houstonpress.com/profile?newsletter=11582352" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Promotions Newsletter")" title="">
Promotions Newsletter
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/flipbooks" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Flipbook Archive")" title="">
Flipbook Archive
</a>
</li>
</ul>
</li>
<li class="uk-parent">
<a href="https://www.houstonpress.com/about" target="_self" class="fdn-custom-footer-navigation-link-block-row-header">
More
</a>
<ul class="uk-nav-sub uk-child-width-1-2 uk-flex uk-flex-wrap">
<li>
<a href="https://www.houstonpress.com/about" target="_self" onclick="ga(" send", "event", "Nav", "Click", "About Us")" title="">
About Us
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/staff" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Staff")" title="">
Staff
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/careers" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Houston Press Careers")" title="">
Houston Press Careers
</a>
</li>
<li>
<a href="https://www.houstonpress.com/advertise" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Local Advertising")" title="">
Local Advertising
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/terms-of-use" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Terms of Use")" title="">
Terms of Use
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/privacy-policy" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Privacy Policy")" title="">
Privacy Policy
</a>
</li>
<li>
<a href="https://www.houstonpress.com/about/contact" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Contact Us")" title="">
Contact Us
</a>
</li>
</ul>
</li>
<li class="uk-parent">
<a href="#" target="_self" class="fdn-custom-footer-navigation-link-block-row-header" uk-totop uk-scroll>
Back to Top
</a>
</li>
</ul>
<div class="fdn-custom-footer-navigation-link-social-block">
<a class="fdn-custom-footer-navigation-link-social-facebook" href="https://www.facebook.com/HoustonPress" onclick="ga(" send", "event", "Nav", "Click", "Facebook")" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-facebook"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-instagram" href="https://instagram.com/houstonpress" onclick="ga(" send", "event", "Nav", "Click", "Instagram")" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-instagram"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-twitter" href="https://twitter.com/houstonpress" onclick="ga(" send", "event", "Nav", "Click", "Twitter")" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-twitter"></i>
</a>
</div>
</div>
</div>
<div class="fdn-custom-footer-navigation-link-block-narrow-legal-links">
<div class="fdn-custom-footer-navigation-link-block-narrow-legal-link-row">
<a href="https://www.houstonpress.com/about/californiaPrivacyPolicy" target="_self" onclick="ga(" send", "event", "Nav", "Click", "California Privacy Policy")" title="">
California Privacy Policy
</a>
<a href="https://www.houstonpress.com/about/californiaPrivacyPolicy#CollectionNotice" target="_self" onclick="ga(" send", "event", "Nav", "Click", "California Collection Notice")" title="">
California Collection Notice
</a>
</div>
<div class="fdn-custom-footer-navigation-link-block-narrow-legal-link-row">
<a href="https://www.houstonpress.com/about/californiaPrivacyPolicy#DoNotSell" target="_self" onclick="ga(" send", "event", "Nav", "Click", "Do Not Sell My Info")" title="">
Do Not Sell My Info
</a>
</div>
</div>
</div>
<div class="uk-flex uk-flex-center uk-margin-medium-top custom-footer-row-bottom custom-footer-row">
<div class="uk-text-center">
<div class="fdn-copyright-text">
Use of this website constitutes acceptance of our
<a href="/about/terms-of-use">terms of use</a>,
<a href="/about/cookies">our cookies policy</a>, and our
<a href="/about/privacy-policy">privacy policy</a>
The Houston Press may earn a portion of sales from products & services purchased through links on our site from our
affiliate partners.
&copy;2021
Houston Press, LP. All rights reserved.
</div>
<div class="fdn-copyright-text uk-margin-small-top">
<a class="fdn-copyright-link" href="https://publishwithfoundation.com/" target="_blank">
<img width="110" alt="Powered By Foundation" src="/images/PoweredByFoundation.svg">
</a>
</div>
</div>
</div>
</div><script>
  !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '701597819931765'); // Insert your pixel ID here.
  fbq('track', 'PageView');
  </script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=701597819931765&ev=PageView&noscript=1"/></noscript>
<script type='text/javascript'>
  var _sf_async_config = _sf_async_config || {};
  var _sf_async_config = {};
  _sf_async_config.uid = 10424;
  _sf_async_config.domain = 'houstonpress.com';
  _sf_async_config.useCanonical = true;
  _sf_async_config.sections = '/music';
  _sf_async_config.authors = 'Pete Vonder Haar';

  (function() {
    function loadChartbeat() {
        window._sf_endpt = (new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
    }
    var oldonload = document.ready;
    document.ready = (typeof document.ready != 'function') ? loadChartbeat : function() {
        oldonload();
        loadChartbeat();
    };
  })();
  </script>

<script>
   var ezt = ezt ||[];

   (function(){
     var elem = document.createElement('script');
     elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://pixel") + ".quantserve.com/aquant.js?a=p-a4LDpi_DEopn-";
     elem.async = true;
     elem.type = "text/javascript";
     var scpt = document.getElementsByTagName('script')[0];
     scpt.parentNode.insertBefore(elem,scpt);
   }());


   ezt.push({qacct: 'p-a4LDpi_DEopn-',
         uid: ''
             });
  </script>
 <noscript>
    <img src="//pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
  </noscript>


<script>
  (function(w,d,t,u){
      var a=d.createElement(t);a.async=1;a.src=u+"?url="+encodeURIComponent(w.location.href)+"&ref="+encodeURIComponent(d.referrer);
      var s=d.getElementsByTagName(t)[0]; s.parentNode.insertBefore(a,s);
  })(window, document, 'script', 'https://a.ad.gt/api/v1/u/matches/322')
  </script>

</div>
</div>
<div class="ev-grid-zone ev-closer-zone" data-ev-zone="Closer">
<div class="ev-grid-col uk-width-1-1">
</div>
</div>
</div>
</div>
</body>
</html>
